summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-04-14 20:41:55 +0200
committerMichael Orlitzky <mjo@gentoo.org>2024-04-15 21:14:03 -0400
commite03cc45995170cab2f8a2bb783bc8fcd23c885b9 (patch)
tree90f451e9382df14128b98178a6684522aac56e06
parentsys-apps/systemd-utils: add basename fix (diff)
downloadgentoo-e03cc45995170cab2f8a2bb783bc8fcd23c885b9.tar.gz
gentoo-e03cc45995170cab2f8a2bb783bc8fcd23c885b9.tar.bz2
gentoo-e03cc45995170cab2f8a2bb783bc8fcd23c885b9.zip
net-analyzer/nagios-check_mysql_health: EAPI8 bump
Closes: https://github.com/gentoo/gentoo/pull/36259 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
-rw-r--r--net-analyzer/nagios-check_mysql_health/nagios-check_mysql_health-2.2.2-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-analyzer/nagios-check_mysql_health/nagios-check_mysql_health-2.2.2-r1.ebuild b/net-analyzer/nagios-check_mysql_health/nagios-check_mysql_health-2.2.2-r1.ebuild
new file mode 100644
index 000000000000..3de8e319875f
--- /dev/null
+++ b/net-analyzer/nagios-check_mysql_health/nagios-check_mysql_health-2.2.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="${PN#nagios-}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Nagios plugin for checking MySQL server health"
+HOMEPAGE="https://labs.consol.de/nagios/check_mysql_health/"
+SRC_URI="https://labs.consol.de/assets/downloads/nagios/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Found by grepping for "use " in the built
+# plugins-scripts/check_mysql_health.
+RDEPEND="
+ dev-perl/DBD-mysql
+ dev-perl/DBI
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Temp
+ virtual/perl-Net-Ping
+ virtual/perl-Time-HiRes
+ "
+
+src_configure() {
+ # Should match net-analyzer/{monitoring,nagios}-plugins.
+ econf --libexecdir="/usr/$(get_libdir)/nagios/plugins"
+}
+
+# Here we should have a pkg_preinst() that creates the nagios user/group
+# (using the same command from e.g. net-analyzer/nagios-plugins). But
+# right now, the build system for check_mysql_health has a bug: it
+# doesn't use the configured user (INSTALL_OPTIONS aren't passed to
+# /usr/bin/install), so it's pointless. Don't forget to inherit
+# user.eclass!