summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew White <mehw.is.me@inventati.org>2023-08-01 14:41:23 +0000
committerSam James <sam@gentoo.org>2024-03-23 08:29:09 +0000
commite04e0ee75ec9a30fada6d3670283804c24d47712 (patch)
tree3ab2d6925c4da48f8664ee42c14f1ce9f20138cb
parentmedia-sound/audacity: drop 3.2.5-r1 (diff)
downloadgentoo-e04e0ee75ec9a30fada6d3670283804c24d47712.tar.gz
gentoo-e04e0ee75ec9a30fada6d3670283804c24d47712.tar.bz2
gentoo-e04e0ee75ec9a30fada6d3670283804c24d47712.zip
app-doc/audacity: HTML reference manual for Audacity
Closes: https://bugs.gentoo.org/911561 Package-Manager: portage-3.0.49-r1 Signed-off-by: Matthew White <mehw.is.me@inventati.org> Closes: https://github.com/gentoo/gentoo/pull/32128 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-doc/audacity/Manifest2
-rw-r--r--app-doc/audacity/audacity-3.3.3.ebuild26
-rw-r--r--app-doc/audacity/audacity-3.4.2.ebuild26
-rw-r--r--app-doc/audacity/audacity-9999.ebuild26
-rw-r--r--app-doc/audacity/metadata.xml19
5 files changed, 99 insertions, 0 deletions
diff --git a/app-doc/audacity/Manifest b/app-doc/audacity/Manifest
new file mode 100644
index 000000000000..d0cfb5f2b720
--- /dev/null
+++ b/app-doc/audacity/Manifest
@@ -0,0 +1,2 @@
+DIST audacity-manual-3.3.3.tar.gz 22938196 BLAKE2B b2646c84859a10e2f2d80abe44c3dc33021fda92b9e60e746fdae95ea7b32003d2a804c7ef8f88b3c3e3efdce8e0f3b2acf846753bede9d05dbbb92777c1055c SHA512 d522b94157f091206341a05b67dbf3c776fedb5a8329f4301244a9ad9cb5f638d49dda11fbb11d376f8f5c4509f1984933d388c44830c8c2ce0c2b59ee7607f9
+DIST audacity-manual-3.4.2.tar.gz 23305736 BLAKE2B 641c4d0fc70eece83906d4c2df427037ff675cab179860f4d637ffcb38b9390409557bcc11e819657c86ff99c3fce513b1f877a1e9c5597157881392e5dc3ce7 SHA512 0664d7c925c9e2c3a15e7b403ef2b8752ce219c40f16e361fc567794ddac92d94bdc93ddb73ac9e4251ab26c352cf072d62f765b5644df3a53febb1babfd6fbe
diff --git a/app-doc/audacity/audacity-3.3.3.ebuild b/app-doc/audacity/audacity-3.3.3.ebuild
new file mode 100644
index 000000000000..c033739b6a0e
--- /dev/null
+++ b/app-doc/audacity/audacity-3.3.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="HTML reference manual for Audacity"
+HOMEPAGE="https://www.audacityteam.org/"
+
+if [[ ${PV} = 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/audacity/audacity-manual.git"
+else
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/help"
+ SRC_URI="amd64? ( https://github.com/audacity/audacity-manual/releases/download/v${PV}/audacity-manual-${PV}.tar.gz )"
+fi
+
+LICENSE="CC-BY-3.0"
+SLOT="0"
+
+src_install() {
+ docinto html
+ dodoc -r "${S}"/manual/{m,man}
+ dodoc "${S}"/manual/{favicon.ico,index.html,quick_help.html}
+ dosym ../../doc/${PF}/html /usr/share/${PN}/help/manual
+}
diff --git a/app-doc/audacity/audacity-3.4.2.ebuild b/app-doc/audacity/audacity-3.4.2.ebuild
new file mode 100644
index 000000000000..c033739b6a0e
--- /dev/null
+++ b/app-doc/audacity/audacity-3.4.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="HTML reference manual for Audacity"
+HOMEPAGE="https://www.audacityteam.org/"
+
+if [[ ${PV} = 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/audacity/audacity-manual.git"
+else
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/help"
+ SRC_URI="amd64? ( https://github.com/audacity/audacity-manual/releases/download/v${PV}/audacity-manual-${PV}.tar.gz )"
+fi
+
+LICENSE="CC-BY-3.0"
+SLOT="0"
+
+src_install() {
+ docinto html
+ dodoc -r "${S}"/manual/{m,man}
+ dodoc "${S}"/manual/{favicon.ico,index.html,quick_help.html}
+ dosym ../../doc/${PF}/html /usr/share/${PN}/help/manual
+}
diff --git a/app-doc/audacity/audacity-9999.ebuild b/app-doc/audacity/audacity-9999.ebuild
new file mode 100644
index 000000000000..c033739b6a0e
--- /dev/null
+++ b/app-doc/audacity/audacity-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="HTML reference manual for Audacity"
+HOMEPAGE="https://www.audacityteam.org/"
+
+if [[ ${PV} = 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/audacity/audacity-manual.git"
+else
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/help"
+ SRC_URI="amd64? ( https://github.com/audacity/audacity-manual/releases/download/v${PV}/audacity-manual-${PV}.tar.gz )"
+fi
+
+LICENSE="CC-BY-3.0"
+SLOT="0"
+
+src_install() {
+ docinto html
+ dodoc -r "${S}"/manual/{m,man}
+ dodoc "${S}"/manual/{favicon.ico,index.html,quick_help.html}
+ dosym ../../doc/${PF}/html /usr/share/${PN}/help/manual
+}
diff --git a/app-doc/audacity/metadata.xml b/app-doc/audacity/metadata.xml
new file mode 100644
index 000000000000..204ad578eda0
--- /dev/null
+++ b/app-doc/audacity/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>mehw.is.me@inventati.org</email>
+ <name>Matthew White</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proaudio@gentoo.org</email>
+ <name>Gentoo ProAudio Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">audacity/audacity-manual</remote-id>
+ </upstream>
+</pkgmetadata>