summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-11-27 13:21:23 -0600
committerWilliam Hubbs <williamh@gentoo.org>2023-11-27 16:52:46 -0600
commite0512a7cc43063f2bd1348f965332adf66e98430 (patch)
treeb4a4f992d70f7dc17f68c4ca9236bcbcf5237fb8
parentsci-libs/gloo: fix ssl3 build (diff)
downloadgentoo-e0512a7cc43063f2bd1348f965332adf66e98430.tar.gz
gentoo-e0512a7cc43063f2bd1348f965332adf66e98430.tar.bz2
gentoo-e0512a7cc43063f2bd1348f965332adf66e98430.zip
app-containers/skopeo: sync live
Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--app-containers/skopeo/skopeo-9999.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/app-containers/skopeo/skopeo-9999.ebuild b/app-containers/skopeo/skopeo-9999.ebuild
index 9fc4a1466912..b7a859d817d5 100644
--- a/app-containers/skopeo/skopeo-9999.ebuild
+++ b/app-containers/skopeo/skopeo-9999.ebuild
@@ -16,14 +16,11 @@ else
fi
# main
-LICENSE="Apache-2.0"
-# deps
-LICENSE+=" BSD BSD-2 CC-BY-SA-4.0 ISC MIT"
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT"
SLOT="0"
IUSE="btrfs device-mapper rootless"
-RDEPEND="
- app-containers/containers-common
+COMMON_DEPEND="
>=app-crypt/gpgme-1.5.5:=
>=dev-libs/libassuan-2.4.3:=
btrfs? ( >=sys-fs/btrfs-progs-4.0.1 )
@@ -33,7 +30,11 @@ RDEPEND="
# TODO: Is this really needed? cause upstream doesnt mention it https://github.com/containers/skopeo/blob/main/install.md#building-from-source
# dev-libs/libgpg-error:=
-DEPEND="${RDEPEND}"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="
+ ${COMMON_DEPEND}
+ app-containers/containers-common
+"
BDEPEND="dev-go/go-md2man"
RESTRICT="test"