summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-05 06:29:15 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-05 06:29:15 +0100
commite05a532f1f3d4a9ce9dd3744034f48bf80ba4dc0 (patch)
tree0a518afb08402efa427415be44e5b7ff0d2cf064
parentdev-libs/c-blosc2: Bump to 2.11.0 (diff)
downloadgentoo-e05a532f1f3d4a9ce9dd3744034f48bf80ba4dc0.tar.gz
gentoo-e05a532f1f3d4a9ce9dd3744034f48bf80ba4dc0.tar.bz2
gentoo-e05a532f1f3d4a9ce9dd3744034f48bf80ba4dc0.zip
dev-python/uvicorn: Bump to 0.24.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/uvicorn/Manifest1
-rw-r--r--dev-python/uvicorn/uvicorn-0.24.0.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/uvicorn/Manifest b/dev-python/uvicorn/Manifest
index 391d8c174d47..b28cb1108c0d 100644
--- a/dev-python/uvicorn/Manifest
+++ b/dev-python/uvicorn/Manifest
@@ -1 +1,2 @@
DIST uvicorn-0.23.2.gh.tar.gz 723155 BLAKE2B 03edb0b6c7be001be868636a77b818491d71e28277e22f252d650c2d9452e5018470fa3cf60300a8f4358d548f794e95a1bf877ac02ed30574a14dc56cea9841 SHA512 a575482ed261dff3a74a5e04387b36dda55d5975a635ca5c124770b7bbfcf764ea420b0b78b9396e4eaa8b839031933aefc7867befb46d18f39f3df5115eb77a
+DIST uvicorn-0.24.0.gh.tar.gz 715220 BLAKE2B b71273545ae244544b5336524bf4ad1f386c8bb2b1addc501514833f37376f8a09a1d4dfc2272c3b62555337a20750af827c9a7a4c3bffc6327a9d1809869cfa SHA512 98b58ce17a1f072f36923b1b616f818cbadd091256ce1281a5236268ba2378d212384d9c3390b5903edfda5c692a67935051379e31732df45422595a88c69232
diff --git a/dev-python/uvicorn/uvicorn-0.24.0.ebuild b/dev-python/uvicorn/uvicorn-0.24.0.ebuild
new file mode 100644
index 000000000000..a131d346d201
--- /dev/null
+++ b/dev-python/uvicorn/uvicorn-0.24.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Lightning-fast ASGI server implementation"
+HOMEPAGE="
+ https://www.uvicorn.org/
+ https://github.com/encode/uvicorn/
+ https://pypi.org/project/uvicorn/
+"
+# as of 0.21.0, no tests in sdist
+SRC_URI="
+ https://github.com/encode/uvicorn/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test-rust"
+
+RDEPEND="
+ >=dev-python/asgiref-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ >=dev-python/h11-0.8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/a2wsgi[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/websockets-10.4[${PYTHON_USEDEP}]
+ dev-python/wsproto[${PYTHON_USEDEP}]
+ test-rust? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ dev-python/watchfiles[${PYTHON_USEDEP}]
+ )
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # too long path for unix socket
+ tests/test_config.py::test_bind_unix_socket_works_with_reload_or_workers
+ # need unpackaged httptools
+ "tests/middleware/test_logging.py::test_trace_logging_on_http_protocol[httptools]"
+ tests/protocols/test_http.py::test_fragmentation
+ # TODO
+ tests/protocols/test_websocket.py::test_connection_lost_before_handshake_complete
+ "tests/protocols/test_websocket.py::test_asgi_return_value[H11Protocol-WebSocketProtocol]"
+ )
+ case ${EPYTHON} in
+ pypy3)
+ # TODO
+ EPYTEST_DESELECT+=(
+ tests/middleware/test_logging.py::test_running_log_using_fd
+ )
+ ;;
+ esac
+
+ epytest
+}
+
+pkg_postinst() {
+ optfeature "auto reload on file changes" dev-python/watchfiles
+}