summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2017-10-15 19:55:09 -0400
committerJason A. Donenfeld <zx2c4@gentoo.org>2017-10-16 03:13:38 +0200
commite05c0d5549b494c5e4667b0701275b094d46c972 (patch)
tree926f18f5178cd9b767bb30e8858be58a3bf7ad8c
parentgnustep-base/libobjc2: [QA] Add cmake-utils_src_prepare (diff)
downloadgentoo-e05c0d5549b494c5e4667b0701275b094d46c972.tar.gz
gentoo-e05c0d5549b494c5e4667b0701275b094d46c972.tar.bz2
gentoo-e05c0d5549b494c5e4667b0701275b094d46c972.zip
net-wireless/uhd: Fix building with GCC-6
Bug: https://bugs.gentoo.org/611680 Package-Manager: Portage-2.3.10, Repoman-2.3.3
-rw-r--r--net-wireless/uhd/files/uhd-3.8.5-gcc6.patch25
-rw-r--r--net-wireless/uhd/uhd-3.8.5.ebuild4
-rw-r--r--net-wireless/uhd/uhd-3.9.6.ebuild2
3 files changed, 31 insertions, 0 deletions
diff --git a/net-wireless/uhd/files/uhd-3.8.5-gcc6.patch b/net-wireless/uhd/files/uhd-3.8.5-gcc6.patch
new file mode 100644
index 000000000000..c2e5e00f70d6
--- /dev/null
+++ b/net-wireless/uhd/files/uhd-3.8.5-gcc6.patch
@@ -0,0 +1,25 @@
+Bug: https://bugs.gentoo.org/611680
+Backported from: https://github.com/EttusResearch/uhd/commit/b6ad4c0531ef56f4e197cccd06f1d11fc89e4aab
+
+--- a/host/lib/usrp/dboard/db_cbx.cpp
++++ b/host/lib/usrp/dboard/db_cbx.cpp
+@@ -38,7 +38,7 @@ sbx_xcvr::cbx::~cbx(void){
+ /* NOP */
+ }
+
+-void sbx_xcvr::cbx::write_lo_regs(dboard_iface::unit_t unit, std::vector<boost::uint32_t> &regs)
++void sbx_xcvr::cbx::write_lo_regs(dboard_iface::unit_t unit, const std::vector<boost::uint32_t> &regs)
+ {
+ BOOST_FOREACH(boost::uint32_t reg, regs)
+ {
+--- a/host/lib/usrp/dboard/db_sbx_common.hpp
++++ b/host/lib/usrp/dboard/db_sbx_common.hpp
+@@ -225,7 +225,7 @@ class sbx_xcvr : public xcvr_dboard_base{
+ /*! This is the registered instance of the wrapper class, sbx_base. */
+ sbx_xcvr *self_base;
+ private:
+- void write_lo_regs(dboard_iface::unit_t unit, std::vector<boost::uint32_t> &regs);
++ void write_lo_regs(dboard_iface::unit_t unit, const std::vector<boost::uint32_t> &regs);
+ max287x_iface::sptr _txlo;
+ max287x_iface::sptr _rxlo;
+ };
diff --git a/net-wireless/uhd/uhd-3.8.5.ebuild b/net-wireless/uhd/uhd-3.8.5.ebuild
index 1474f296e8ca..d6787b88c5f4 100644
--- a/net-wireless/uhd/uhd-3.8.5.ebuild
+++ b/net-wireless/uhd/uhd-3.8.5.ebuild
@@ -34,7 +34,11 @@ DEPEND="${RDEPEND}
S="${WORKDIR}"/uhd-release_00$(get_version_component_range 1)_00$(get_version_component_range 2)_00$(get_version_component_range 3)/host
+PATCHES=( "${FILESDIR}"/${P}-gcc6.patch )
+
src_prepare() {
+ cmake-utils_src_prepare
+
gnome2_environment_reset #534582
#this may not be needed in 3.4.3 and above, please verify
diff --git a/net-wireless/uhd/uhd-3.9.6.ebuild b/net-wireless/uhd/uhd-3.9.6.ebuild
index f1f73a61cafb..57e303285555 100644
--- a/net-wireless/uhd/uhd-3.9.6.ebuild
+++ b/net-wireless/uhd/uhd-3.9.6.ebuild
@@ -36,6 +36,8 @@ DEPEND="${RDEPEND}
S="${WORKDIR}"/uhd-release_00$(get_version_component_range 1)_00$(get_version_component_range 2)_00$(get_version_component_range 3)/host
src_prepare() {
+ cmake-utils_src_prepare
+
gnome2_environment_reset #534582
#this may not be needed in 3.4.3 and above, please verify