summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Flogeras <dflogeras2@gmail.com>2020-09-08 18:41:01 -0300
committerAndreas Sturmlechner <asturm@gentoo.org>2021-01-08 00:56:50 +0100
commite0646fe8cd8102d0c0d2a467c2a6b7018429fbfa (patch)
treeff7ccd85094e545e5e740b152eb5f0601f936dce
parentsci-visualization/veusz: Use qmake-utils (diff)
downloadgentoo-e0646fe8.tar.gz
gentoo-e0646fe8.tar.bz2
gentoo-e0646fe8.zip
media-libs/kcolorpicker: New package
This package (and media-libs/kimageannotator) will soon be dependencies of kde-apps/spectacle to add annotation capabilities. I have been maintaining both in the GURU overlay since about May 2020. Suggested-by: Andreas Sturmlechner <asturm@gentoo.org> Bug: https://bugs.gentoo.org/723758 Package-Manager: Portage-3.0.4, Repoman-2.3.23 Signed-off-by: David Flogeras <dflogeras2@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/17477 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-libs/kcolorpicker/Manifest1
-rw-r--r--media-libs/kcolorpicker/kcolorpicker-0.1.4.ebuild41
-rw-r--r--media-libs/kcolorpicker/metadata.xml16
3 files changed, 58 insertions, 0 deletions
diff --git a/media-libs/kcolorpicker/Manifest b/media-libs/kcolorpicker/Manifest
new file mode 100644
index 000000000000..f1b0cd4c0c97
--- /dev/null
+++ b/media-libs/kcolorpicker/Manifest
@@ -0,0 +1 @@
+DIST kColorPicker-0.1.4.tar.gz 11438 BLAKE2B 407211d5938d78aa8bfe193c037a3224ab51cacec7213e4526689ba38a800db2f5df4b0804cd3cc428765a22f426b50d870a355ce07d3f40ff231b8d4f44bf93 SHA512 135b8e0e189feb724f6a4f6a09b8e18922d294fbb3c80cd8522acec272ad0503eff5bf375ae7d58b1dd2f891dc0df187b2a3442726f8ff980583c475090b8673
diff --git a/media-libs/kcolorpicker/kcolorpicker-0.1.4.ebuild b/media-libs/kcolorpicker/kcolorpicker-0.1.4.ebuild
new file mode 100644
index 000000000000..4867e8b9369d
--- /dev/null
+++ b/media-libs/kcolorpicker/kcolorpicker-0.1.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VIRTUALX_REQUIRED="test"
+inherit cmake virtualx
+
+MY_PN=kColorPicker
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Qt based color picker with popup menu"
+HOMEPAGE="https://github.com/ksnip/kColorPicker"
+SRC_URI="https://github.com/ksnip/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5[png]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-qt/qttest:5 )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ local mycmakeargs+=(
+ -DBUILD_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ virtx cmake_src_test
+}
diff --git a/media-libs/kcolorpicker/metadata.xml b/media-libs/kcolorpicker/metadata.xml
new file mode 100644
index 000000000000..e8952720fcef
--- /dev/null
+++ b/media-libs/kcolorpicker/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dflogeras2@gmail.com</email>
+ <name>David Flogeras</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">QToolButton with color popup menu with lets you
+ select a color. The popup features a color dialog button which can be
+ used to add custom colors to the popup menu.
+ </longdescription>
+</pkgmetadata>