summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-10 07:50:20 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-10 08:38:18 +0300
commite06ca4cd3b18b3c185547efbcb3d4aee87d89a1a (patch)
tree6a5378e42e50358a786af81c36ab26cf143afb57
parentdev-python/jsonschema: add 4.16.0 (diff)
downloadgentoo-e06ca4cd.tar.gz
gentoo-e06ca4cd.tar.bz2
gentoo-e06ca4cd.zip
dev-python/phonenumbers: add 8.12.55
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/phonenumbers/Manifest1
-rw-r--r--dev-python/phonenumbers/phonenumbers-8.12.55.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/phonenumbers/Manifest b/dev-python/phonenumbers/Manifest
index a8566fa2d9e6..8ec2b903a865 100644
--- a/dev-python/phonenumbers/Manifest
+++ b/dev-python/phonenumbers/Manifest
@@ -1,2 +1,3 @@
DIST python-phonenumbers-8.12.53.gh.tar.gz 4904940 BLAKE2B c8da67f781c71265faa4d24e5cadf7d2c4e707de6f6fc2efae37f0b846cafd6c00814188c2d89d98ec0fb7dbeef9fedc45dc908adf117643bc2b2a0ab56a4496 SHA512 aa699e5df1b612bbcf384e01b80251099872e67fd5632dab35e53861ab6b28157266ac0a1700f4371a0a2975f0484256fb46b6287b87dc8e69aca85323475490
DIST python-phonenumbers-8.12.54.gh.tar.gz 4905001 BLAKE2B 5fc206b3dd5f5cc96ecfc91b33369fb12d8a11245f846039478bf77f9dbc8e1bfe0e169eb6f1c360ac2a730f79b512178b115f82434790baeb3b2d26d5eaa370 SHA512 0da4f3ffa57f0c2ddaf843eea1440b33844be7ee45122a21d00b5630b720eac059777dca2051e00baf39158737478d5077f97ec6b9293528b11a9844294a621c
+DIST python-phonenumbers-8.12.55.gh.tar.gz 4905987 BLAKE2B 3c05fbe261f9c347bdccb9e664f0005f3f67120df5a494b105780ac5f00a407289bd6be6bbaefbf843937193b760b772e1d8c298a6676770f97d7e6a3d16f25a SHA512 f1aaecd70d761aaa2b6b53d5dc03624f1a64cfb8733b2ac3260bb295be527238755659b55b5d79b6a49a06c56616517afb2cd56b3f39f5eba8dcc27b61e4a6b5
diff --git a/dev-python/phonenumbers/phonenumbers-8.12.55.ebuild b/dev-python/phonenumbers/phonenumbers-8.12.55.ebuild
new file mode 100644
index 000000000000..baab22b23fc7
--- /dev/null
+++ b/dev-python/phonenumbers/phonenumbers-8.12.55.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Python port of Google's libphonenumber"
+HOMEPAGE="
+ https://github.com/daviddrysdale/python-phonenumbers/
+ https://pypi.org/project/phonenumbers/
+"
+SRC_URI="
+ https://github.com/daviddrysdale/python-phonenumbers/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}/python
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( ../README.md )
+
+python_test() {
+ "${EPYTHON}" testwrapper.py -v || die "Tests failed with ${EPYTHON}"
+}