summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-31 16:43:26 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-31 17:42:24 +0200
commite0855f6d069f394582bd55ab7042ba37e1515c44 (patch)
tree90f98014fbe37beec8525b682cb8aa164e2f38f1
parentdev-python/pyrsistent: Backport py38 to 0.15.6 (py2) (diff)
downloadgentoo-e0855f6d.tar.gz
gentoo-e0855f6d.tar.bz2
gentoo-e0855f6d.zip
dev-python/fixtures: Port to py39
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/fixtures/fixtures-3.0.0.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/dev-python/fixtures/fixtures-3.0.0.ebuild b/dev-python/fixtures/fixtures-3.0.0.ebuild
index d659f853923e..0f6eb5d60dcc 100644
--- a/dev-python/fixtures/fixtures-3.0.0.ebuild
+++ b/dev-python/fixtures/fixtures-3.0.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{6..9} pypy3 )
inherit distutils-r1
@@ -25,7 +25,14 @@ RDEPEND="
>=dev-python/testtools-0.9.22[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
test? ( dev-python/mock[${PYTHON_USEDEP}] )"
-#DISTUTILS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ # broken on py3.9
+ # https://github.com/testing-cabal/fixtures/issues/44
+ sed -i -e 's:test_patch_classmethod_with:_&:' \
+ fixtures/tests/_fixtures/test_monkeypatch.py || die
+ distutils-r1_src_prepare
+}
python_test() {
emake check