summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2020-01-26 09:13:40 +0800
committerBenda Xu <heroxbd@gentoo.org>2020-01-26 09:19:01 +0800
commite099f966bfcfe82d06cf946568d6874ff37e1be4 (patch)
tree1125802c721dc57667ec96cb62d16e3bd2306d0b
parentprofiles/alpha: Remove extra " (diff)
downloadgentoo-e099f966bfc.tar.gz
gentoo-e099f966bfc.tar.bz2
gentoo-e099f966bfc.zip
dev-python/matplotlib: bump to 3.1.2.
- Unbundle qhull. - Depend on pyobject:3[cairo] for USE="gtk3 cairo". - p/arch/arm64/package.use.mask: mask USE=wxwidgets dev-python/wxpython does not have arm64 keyword. Closes: https://bugs.gentoo.org/671796 Closes: https://bugs.gentoo.org/680176 Closes: https://bugs.gentoo.org/665560 Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
-rw-r--r--dev-python/matplotlib/Manifest1
-rw-r--r--dev-python/matplotlib/files/matplotlib-3.1.2-no-jqueryui-download.patch15
-rw-r--r--dev-python/matplotlib/files/matplotlib-3.1.2-qhull.patch20
-rw-r--r--dev-python/matplotlib/matplotlib-3.1.2.ebuild244
-rw-r--r--profiles/arch/arm64/package.use.mask4
5 files changed, 284 insertions, 0 deletions
diff --git a/dev-python/matplotlib/Manifest b/dev-python/matplotlib/Manifest
index 5ce2a199f71e..702259318561 100644
--- a/dev-python/matplotlib/Manifest
+++ b/dev-python/matplotlib/Manifest
@@ -1,2 +1,3 @@
DIST matplotlib-2.2.2.tar.gz 37317332 BLAKE2B 4120265263c5b1e4ab57f7c0eb7a477b4071a5f219d1d6328d6ed51d44460217c7c4da82a4b7d13c6ba9f80308406a217f2dbcfa310f3137cbe8bc56a9ef0eef SHA512 1d21ef821190f22354098f8f0db6449f237acbf3c1419ab3815ecd4e9c6922fd3f00c4a8f60858e319b55b6fb2e8fe2922c0bf8e72b204e7edff0b409cf76320
DIST matplotlib-2.2.4.tar.gz 36974286 BLAKE2B 9c4c69163a23ff02107ee155f72e142dcf31ba965f6a20f468b96f3f4b70b95ff6caade6b14bcbacd5b231848d2000ce6af9f113feefb41d6e186725349490d3 SHA512 968f5731b8a9a2c5575403c60d5b0a98a452b33094e520be44f4d901f892d082babc8fc1d73c519e1ff2baf756f3cb7652f4b796e166d66dfda31f7e50c58139
+DIST matplotlib-3.1.2.tar.gz 40909582 BLAKE2B 670907670335ca13ec01f3acf036fd502ce34abd12666b2e0d10867c6115a0fe80039326cee89099471aa6b3bbd25f1ca4aa837072dea624ee41984da9f647be SHA512 2eff3c0525d01824ed758a87f50a3f6094767b580fca1eae4e9dbc2cc972af3d0cc3ac9615e576c5685e8bfc1ec90754bc826635f4f2a919d0b26bbb686cccab
diff --git a/dev-python/matplotlib/files/matplotlib-3.1.2-no-jqueryui-download.patch b/dev-python/matplotlib/files/matplotlib-3.1.2-no-jqueryui-download.patch
new file mode 100644
index 000000000000..145f321039b9
--- /dev/null
+++ b/dev-python/matplotlib/files/matplotlib-3.1.2-no-jqueryui-download.patch
@@ -0,0 +1,15 @@
+Index: matplotlib-3.1.2/setup.py
+===================================================================
+--- matplotlib-3.1.2.orig/setup.py
++++ matplotlib-3.1.2/setup.py
+@@ -125,7 +125,9 @@ cmdclass['build_ext'] = BuildExtraLibrar
+
+
+ def _download_jquery_to(dest):
+- if os.path.exists(os.path.join(dest, "jquery-ui-1.12.1")):
++ # Avoid downloading jquery ui during emerge: we already have it in
++ # pypi's tarball. use this!
++ if True:
+ return
+
+ # If we are installing from an sdist, use the already downloaded jquery-ui
diff --git a/dev-python/matplotlib/files/matplotlib-3.1.2-qhull.patch b/dev-python/matplotlib/files/matplotlib-3.1.2-qhull.patch
new file mode 100644
index 000000000000..e02e03e65edb
--- /dev/null
+++ b/dev-python/matplotlib/files/matplotlib-3.1.2-qhull.patch
@@ -0,0 +1,20 @@
+Index: matplotlib-3.1.2/setupext.py
+===================================================================
+--- matplotlib-3.1.2.orig/setupext.py
++++ matplotlib-3.1.2/setupext.py
+@@ -839,14 +839,7 @@ class Qhull(SetupPackage):
+ name = "qhull"
+
+ def add_flags(self, ext):
+- # Qhull doesn't distribute pkg-config info, so we have no way of
+- # knowing whether a system install is recent enough. Thus, always use
+- # the vendored version.
+- ext.include_dirs.insert(0, 'extern')
+- ext.sources.extend(sorted(glob.glob('extern/libqhull/*.c')))
+- if sysconfig.get_config_var('LIBM') == '-lm':
+- ext.libraries.extend('m')
+-
++ ext.libraries.extend(['qhull'])
+
+ class TTConv(SetupPackage):
+ name = "ttconv"
diff --git a/dev-python/matplotlib/matplotlib-3.1.2.ebuild b/dev-python/matplotlib/matplotlib-3.1.2.ebuild
new file mode 100644
index 000000000000..db457aa8b799
--- /dev/null
+++ b/dev-python/matplotlib/matplotlib-3.1.2.ebuild
@@ -0,0 +1,244 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_REQ_USE='tk?,threads(+)'
+
+inherit distutils-r1 flag-o-matic virtualx toolchain-funcs prefix
+
+DESCRIPTION="Pure python plotting library with matlab like syntax"
+HOMEPAGE="https://matplotlib.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+# Main license: matplotlib
+# Some modules: BSD
+# matplotlib/backends/qt4_editor: MIT
+# Fonts: BitstreamVera, OFL-1.1
+LICENSE="BitstreamVera BSD matplotlib MIT OFL-1.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="cairo doc excel examples gtk3 latex qt5 test tk wxwidgets"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="
+ test? (
+ cairo latex qt5 tk wxwidgets gtk3
+ )"
+
+COMMON_DEPEND="
+ dev-python/cycler[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.7.1[${PYTHON_USEDEP}]
+ dev-python/python-dateutil:0[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10[${PYTHON_USEDEP}]
+ media-fonts/stix-fonts
+ media-libs/freetype:2
+ media-libs/libpng:0
+ >=media-libs/qhull-2013
+ >=dev-python/kiwisolver-1.0.0[${PYTHON_USEDEP}]
+ cairo? ( dev-python/cairocffi[${PYTHON_USEDEP}] )
+ wxwidgets? ( dev-python/wxpython:*[${PYTHON_USEDEP}] )"
+
+# internal copy of pycxx highly patched
+# dev-python/pycxx
+
+DEPEND="${COMMON_DEPEND}
+ dev-python/versioneer[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ doc? (
+ app-text/dvipng
+ dev-python/colorspacious[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ >=dev-python/numpydoc-0.8[${PYTHON_USEDEP}]
+ <dev-python/numpydoc-0.9
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-gallery-0.3.1[${PYTHON_USEDEP}]
+ dev-python/xlwt[${PYTHON_USEDEP}]
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-fontsrecommended
+ dev-texlive/texlive-latexrecommended
+ media-gfx/graphviz[cairo]
+ )
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/nose-0.11.1[${PYTHON_USEDEP}]
+ )"
+
+RDEPEND="${COMMON_DEPEND}
+ >=dev-python/pyparsing-1.5.6[${PYTHON_USEDEP}]
+ excel? ( dev-python/xlwt[${PYTHON_USEDEP}] )
+ gtk3? (
+ dev-python/pygobject:3[cairo?,${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection] )
+ latex? (
+ virtual/latex-base
+ app-text/ghostscript-gpl
+ app-text/dvipng
+ app-text/poppler[utils]
+ dev-texlive/texlive-fontsrecommended
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-xetex
+ )
+ qt5? ( dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}] )"
+
+# A few C++ source files are written to srcdir.
+# Other than that, the ebuild shall be fit for out-of-source build.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+pkg_setup() {
+ unset DISPLAY # bug #278524
+}
+
+use_setup() {
+ local uword="${2:-${1}}"
+ if use ${1}; then
+ echo "${uword} = True"
+ echo "${uword}agg = True"
+ else
+ echo "${uword} = False"
+ echo "${uword}agg = False"
+ fi
+}
+
+python_prepare_all() {
+# Generates test failures, but fedora does it
+# local PATCHES=(
+# "${FILESDIR}"/${P}-unbundle-pycxx.patch
+# "${FILESDIR}"/${P}-unbundle-agg.patch
+# )
+# rm -r agg24 CXX || die
+# rm -r agg24 || die
+
+# cat > lib/${PN}/externals/six.py <<-EOF
+# from __future__ import absolute_import
+# from six import *
+# EOF
+
+ local PATCHES=(
+ "${FILESDIR}"/${PN}-3.1.2-no-jqueryui-download.patch
+ "${FILESDIR}"/${PN}-3.1.2-qhull.patch
+ )
+
+ sed \
+ -e 's/matplotlib.pyparsing_py[23]/pyparsing/g' \
+ -i lib/matplotlib/{mathtext,fontconfig_pattern}.py \
+ || die "sed pyparsing failed"
+
+ hprefixify setupext.py
+
+ rm -rf libqhull || die
+
+ export XDG_RUNTIME_DIR="${T}/runtime-dir"
+ mkdir "${XDG_RUNTIME_DIR}" || die
+ chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ append-flags -fno-strict-aliasing
+ append-cppflags -DNDEBUG # or get old trying to do triangulation
+ tc-export PKG_CONFIG
+}
+
+python_configure() {
+ mkdir -p "${BUILD_DIR}" || die
+
+ # create setup.cfg (see setup.cfg.template for any changes).
+
+ # common switches.
+ cat > "${BUILD_DIR}"/setup.cfg <<- EOF || die
+ [directories]
+ basedirlist = ${EPREFIX}/usr
+ [provide_packages]
+ pytz = False
+ dateutil = False
+ [packages]
+ tests = $(usex test True False)
+ [gui_support]
+ agg = True
+ pyside = False
+ pysideagg = False
+ qt4 = False
+ qt4agg = False
+ $(use_setup cairo)
+ $(use_setup gtk3)
+ $(use_setup qt5)
+ $(use_setup tk)
+ EOF
+
+ if use gtk3 && use cairo; then
+ echo "gtk3cairo = True" >> "${BUILD_DIR}"/setup.cfg || die
+ else
+ echo "gtk3cairo = False" >> "${BUILD_DIR}"/setup.cfg || die
+ fi
+
+ if python_is_python3; then
+ cat >> "${BUILD_DIR}"/setup.cfg <<- EOF || die
+ gtk = False
+ gtkagg = False
+ wx = False
+ wxagg = False
+ EOF
+ else
+ cat >> "${BUILD_DIR}"/setup.cfg <<-EOF || die
+ $(use_setup gtk2 gtk)
+ $(use_setup wxwidgets wx)
+ EOF
+ fi
+}
+
+wrap_setup() {
+ local MAKEOPTS=-j1
+ local -x MPLSETUPCFG="${BUILD_DIR}"/setup.cfg
+ unset DISPLAY
+ "$@"
+}
+
+python_compile() {
+ wrap_setup distutils-r1_python_compile --build-lib="${BUILD_DIR}"/lib
+}
+
+python_compile_all() {
+ if use doc; then
+ cd doc || die
+
+ # necessary for in-source build
+ local -x PYTHONPATH="${BUILD_DIR}"/build/lib:${PYTHONPATH}
+
+ VARTEXFONTS="${T}"/fonts \
+ emake SPHINXOPTS= O=-Dplot_formats=png:100 html
+ fi
+}
+
+python_test() {
+ wrap_setup distutils_install_for_testing
+
+ virtx "${EPYTHON}" -c "import sys, matplotlib as m; sys.exit(0 if m.test(verbosity=2) else 1)"
+}
+
+python_install() {
+ wrap_setup distutils-r1_python_install
+
+ # mpl_toolkits namespace
+ python_moduleinto mpl_toolkits
+ python_domodule lib/mpl_toolkits/__init__.py
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+
+ distutils-r1_python_install_all
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ find "${D}" -name '*.pth' -delete || die
+}
diff --git a/profiles/arch/arm64/package.use.mask b/profiles/arch/arm64/package.use.mask
index a721782b857c..035197f40aca 100644
--- a/profiles/arch/arm64/package.use.mask
+++ b/profiles/arch/arm64/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Benda Xu <heroxbd@gentoo.org> (2020-01-26)
+# Unkeyworded dep.
+dev-python/matplotlib wxwidgets
+
# Michał Górny <mgorny@gentoo.org> (2020-01-11)
# Unkeyworded dep.
kde-apps/cantor julia