summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-26 18:58:15 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-26 18:59:53 +0100
commite0a5eb36b651a52f482f43c362f811b795534087 (patch)
tree94de13e627b58643627c9bb0801947ae96c6c36b
parentdev-python/iminuit: Migrate to PEP517 build (diff)
downloadgentoo-e0a5eb36.tar.gz
gentoo-e0a5eb36.tar.bz2
gentoo-e0a5eb36.zip
dev-python/aioresponses: Migrate to PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/aioresponses/aioresponses-0.7.3-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/aioresponses/aioresponses-0.7.3-r1.ebuild b/dev-python/aioresponses/aioresponses-0.7.3-r1.ebuild
new file mode 100644
index 000000000000..be27317991b0
--- /dev/null
+++ b/dev-python/aioresponses/aioresponses-0.7.3-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Helper to mock/fake web requests in Python's aiohttp package"
+HOMEPAGE="https://github.com/pnuckowski/aioresponses"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ddt[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # These tests require Internet access
+ tests/test_aioresponses.py::AIOResponsesTestCase::test_address_as_instance_of_url_combined_with_pass_through
+ tests/test_aioresponses.py::AIOResponsesTestCase::test_pass_through_with_origin_params
+)