summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-06-05 19:42:27 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-06-05 19:42:27 +0200
commite0ced691415e8f01e2a7247172c2540fa0376f68 (patch)
treef22e855cbf61dd9aa2e9da24ac4a087d68d64895
parentsys-apps/pcsc-lite: Add python3_{5,6} (diff)
downloadgentoo-e0ced691.tar.gz
gentoo-e0ced691.tar.bz2
gentoo-e0ced691.zip
dev-python/whelk: Add tests, add python3_{5,6}
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--dev-python/whelk/whelk-2.7.1.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-python/whelk/whelk-2.7.1.ebuild b/dev-python/whelk/whelk-2.7.1.ebuild
index 2da1fa7233f7..62139f41888c 100644
--- a/dev-python/whelk/whelk-2.7.1.ebuild
+++ b/dev-python/whelk/whelk-2.7.1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_4 )
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
inherit distutils-r1
@@ -16,5 +16,6 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=""
-RDEPEND="${DEPEND}"
+python_test() {
+ ${EPYTHON} -m unittest discover || die
+}