summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-02 18:28:40 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-02 18:28:40 +0300
commite0dd62a610b21637e4eceab53545fb8b5a8b0442 (patch)
tree62a07f4ffb568aaffe208498b4bebb36878cbc48
parentapp-admin/awscli: add 1.25.66 (diff)
downloadgentoo-e0dd62a6.tar.gz
gentoo-e0dd62a6.tar.bz2
gentoo-e0dd62a6.zip
dev-python/natsort: add 8.2.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/natsort/Manifest1
-rw-r--r--dev-python/natsort/natsort-8.2.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/natsort/Manifest b/dev-python/natsort/Manifest
index 76642bd0fcf3..143aee690d11 100644
--- a/dev-python/natsort/Manifest
+++ b/dev-python/natsort/Manifest
@@ -1 +1,2 @@
DIST natsort-8.1.0.tar.gz 145241 BLAKE2B dcf9ffdb58cfe4d0f7ca0ed74701c8137a87716831dc747c5fb68d187a93c1b7414fa3625c0ed385e727e97c36feb99e9ecc6a41dd3d9da342d357646b5aaf32 SHA512 a065899b124e6a6ee8560ce1882650e35f0c36ddfd3c56462820886b076cd8cdb0121825e30e298af576e07915cc5bc1e90fe3f0b1f7bfb89f816c00665baa22
+DIST natsort-8.2.0.tar.gz 145643 BLAKE2B d101ae2fa1cb009892e9712ece87d3825f3fca7970475e46176e5acbc29481ac79d491f1bae0721d85d3e67ecf39e5f54e2a984f0398356f32a5f0ec18a3e98d SHA512 d7e35c48ee36e69812c26b2cd333c57f1ec70c54017c4f51ed06dbb7619afc11cd1d589035faee700e1adf1e6b759b43ee497685fc88518be62c41957e15884e
diff --git a/dev-python/natsort/natsort-8.2.0.ebuild b/dev-python/natsort/natsort-8.2.0.ebuild
new file mode 100644
index 000000000000..67e29ddcd1e0
--- /dev/null
+++ b/dev-python/natsort/natsort-8.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Natural sorting for Python"
+HOMEPAGE="https://pypi.org/project/natsort/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "sorting results that match most file browsers" "dev-python/pyicu"
+}