summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-04-11 19:41:50 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-04-11 21:23:45 +0200
commite0e08ed094bcde165e05944e1eef52dd1a732a3a (patch)
tree66bcfaaabd42c0eb53c031a9558b4afc94304a0a
parentapp-admin/logsurfer+: migrate to GLEP 81 (diff)
downloadgentoo-e0e08ed0.tar.gz
gentoo-e0e08ed0.tar.bz2
gentoo-e0e08ed0.zip
app-admin/tenshi: migrate to GLEP 81
Also bumped to EAPI=7. Closes: https://bugs.gentoo.org/781206 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--app-admin/tenshi/tenshi-0.17-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-admin/tenshi/tenshi-0.17-r1.ebuild b/app-admin/tenshi/tenshi-0.17-r1.ebuild
new file mode 100644
index 000000000000..ac5ed7cc0b14
--- /dev/null
+++ b/app-admin/tenshi/tenshi-0.17-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Log parsing and notification program"
+HOMEPAGE="https://inversepath.com/tenshi.html https://github.com/inversepath/tenshi"
+SRC_URI="https://github.com/inversepath/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ acct-group/tenshi
+ acct-user/tenshi
+ dev-lang/perl
+ dev-perl/IO-BufferedSelect
+ sys-apps/coreutils
+"
+
+src_prepare() {
+ default
+
+ # Fix for bug #241254
+ sed 's:^docdir =.*:docdir = /usr/share/doc/${PF}:' -i Makefile || die "docdir substitution failed"
+}
+
+src_install() {
+ default
+
+ doman tenshi.8
+ keepdir /var/lib/tenshi
+ newinitd tenshi.openrc-init tenshi
+}
+
+pkg_postinst() {
+ ewarn "The sample config installed to ${ROOT}etc/tenshi/tenshi.conf"
+ ewarn "monitors /var/log/messages which, by default, can not be read"
+ ewarn "by the tenshi user. Make sure that the tenshi user has read"
+ ewarn "permission on all the files that you want tenshi to monitor."
+}