summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-05-01 11:09:45 +0100
committerJames Le Cuirot <chewi@gentoo.org>2024-05-02 17:00:29 +0100
commite0e3e48954f9dccc994d764f7fb5fba64080226e (patch)
tree54929306fd708b38f224bcc866be04c8825f94b5
parentsys-fs/lvm2: backport fix for thin-provisioning-tools version check (diff)
downloadgentoo-e0e3e48954f9dccc994d764f7fb5fba64080226e.tar.gz
gentoo-e0e3e48954f9dccc994d764f7fb5fba64080226e.tar.bz2
gentoo-e0e3e48954f9dccc994d764f7fb5fba64080226e.zip
sys-apps/azure-nvme-utils: New package at 0.1.2_p20240502
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--sys-apps/azure-nvme-utils/Manifest1
-rw-r--r--sys-apps/azure-nvme-utils/azure-nvme-utils-0.1.2_p20240502.ebuild30
-rw-r--r--sys-apps/azure-nvme-utils/metadata.xml14
3 files changed, 45 insertions, 0 deletions
diff --git a/sys-apps/azure-nvme-utils/Manifest b/sys-apps/azure-nvme-utils/Manifest
new file mode 100644
index 000000000000..d391813cb9b9
--- /dev/null
+++ b/sys-apps/azure-nvme-utils/Manifest
@@ -0,0 +1 @@
+DIST azure-nvme-utils-0.1.2_p20240502.tar.gz 11362 BLAKE2B 593a1670af3d01e400afb4cf21e9cb3a6456da3ad7914d020462fb50950a8e6d8255ad14fcb8708d44f55f3170a72f824e0fae942a560bf69c6d9770c4da1d2b SHA512 e4d0f3a400e16dc119b1562ec2abfb1e520ef58de46a36fccd4fd9db773c95ad218cc38a406cb644188ca6c66c7e84292cbcae3dad5f1e4b2c3ae0b24aa5077d
diff --git a/sys-apps/azure-nvme-utils/azure-nvme-utils-0.1.2_p20240502.ebuild b/sys-apps/azure-nvme-utils/azure-nvme-utils-0.1.2_p20240502.ebuild
new file mode 100644
index 000000000000..b7583d7e80d4
--- /dev/null
+++ b/sys-apps/azure-nvme-utils/azure-nvme-utils-0.1.2_p20240502.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake udev
+
+COMMIT="cbf8c65d0d792b7dfc02dcaa55d5ec3077464ee6"
+DESCRIPTION="Utility to help identify Azure NVMe devices"
+HOMEPAGE="https://github.com/Azure/azure-nvme-utils"
+#SRC_URI="https://github.com/Azure/${PN}/archive/refs/tags/v${PV}/${P}.tar.gz"
+SRC_URI="https://github.com/Azure/${PN}/archive/${COMMIT}/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc +lun-fallback"
+
+BDEPEND="
+ doc? ( app-text/pandoc )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DAZURE_LUN_CALCULATION_BY_NSID_ENABLED=$(usex lun-fallback)
+ -DUDEV_RULES_INSTALL_DIR="$(get_udevdir)/rules.d"
+ -DPANDOC_EXECUTABLE="$(usex doc "${BROOT}"/usr/bin/pandoc no)"
+ )
+ cmake_src_configure
+}
diff --git a/sys-apps/azure-nvme-utils/metadata.xml b/sys-apps/azure-nvme-utils/metadata.xml
new file mode 100644
index 000000000000..f6dc52150140
--- /dev/null
+++ b/sys-apps/azure-nvme-utils/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chewi@gentoo.org</email>
+ <name>James Le Cuirot</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Azure/azure-nvme-utils</remote-id>
+ </upstream>
+ <use>
+ <flag name="lun-fallback">Enable fallback LUN calculation via NSID</flag>
+ </use>
+</pkgmetadata>