summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-12-03 18:36:02 -0300
committerPacho Ramos <pacho@gentoo.org>2023-12-18 11:19:11 +0100
commite0eb84fcf3b3aedb8b78963bec0eecb9208baf2c (patch)
treecd3757e18fbb72617fb792b2d11c4fa021868316
parentapp-arch/file-roller: Version bump to 43.1 (diff)
downloadgentoo-e0eb84fcf3b3aedb8b78963bec0eecb9208baf2c.tar.gz
gentoo-e0eb84fcf3b3aedb8b78963bec0eecb9208baf2c.tar.bz2
gentoo-e0eb84fcf3b3aedb8b78963bec0eecb9208baf2c.zip
dev-libs/gjs: Version bump to 1.78.1
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/34118 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--dev-libs/gjs/Manifest1
-rw-r--r--dev-libs/gjs/gjs-1.78.1.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-libs/gjs/Manifest b/dev-libs/gjs/Manifest
index 56f37acbbaf4..ce4c633ffbe7 100644
--- a/dev-libs/gjs/Manifest
+++ b/dev-libs/gjs/Manifest
@@ -1,2 +1,3 @@
DIST gjs-1.76.2.tar.xz 646232 BLAKE2B 66466eeb5f956d5041f4e63ba977dc9a688455770c39bcedd63576f56fde9821ed3c827c470f7e3befbbf7828fbd197706637da458876ec129d6c16323e414e8 SHA512 26b024874ce69a6f58b5fabe006b8d5417971db9de00e21ecd352715b4535f405d162bb81c0cf6b20313f0f78833962080ac1cb9bd42cfff9cf6a74340458540
DIST gjs-1.78.0.tar.xz 653500 BLAKE2B f2b6c3d80f55c1b3365fdc94dcedec357fc21ec7f92eccdf24cc028eb006538057d0d6e3328bc2f743a563ba496da5daa8585fabd6fbf52acd38c990b8a4e8ba SHA512 28ad3ff5c031b8e78622244918994ca5f510e4b403a382e7d0b0bcb9a0611be61e103398773328be4c405b49d7984c089180a5fb603518b412d01a935fb3ceb3
+DIST gjs-1.78.1.tar.xz 654556 BLAKE2B 1d723ad2fd15e7ba6b9194cb90f0c0bc7b89c150604beb11ad95e1628ead2bea7ed8b423e1836736013a31e8ff8f3e2400458faa26dcc95d3a6dc36c65957583 SHA512 9a5d02bacbf82364cf5daa69d6613eb38ef34121eb350b2773b87cf1027ccc1b9905b651275fd71036817e710d834d356ee1cecac2f7c83ff571c39e98360286
diff --git a/dev-libs/gjs/gjs-1.78.1.ebuild b/dev-libs/gjs/gjs-1.78.1.ebuild
new file mode 100644
index 000000000000..3f77c1d06628
--- /dev/null
+++ b/dev-libs/gjs/gjs-1.78.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic gnome.org meson virtualx
+
+DESCRIPTION="Javascript bindings for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Projects/Gjs https://gitlab.gnome.org/GNOME/gjs"
+
+LICENSE="MIT || ( MPL-1.1 LGPL-2+ GPL-2+ )"
+SLOT="0"
+IUSE="+cairo examples readline sysprof test"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.66.0:2
+ dev-libs/libffi:=
+ >=dev-libs/gobject-introspection-1.71.1:=
+ dev-lang/spidermonkey:115
+ cairo? ( x11-libs/cairo[X,glib] )
+ readline? ( sys-libs/readline:0= )
+"
+DEPEND="${RDEPEND}
+ sysprof? ( >=dev-util/sysprof-capture-3.40.1:4 )
+ test? (
+ sys-apps/dbus
+ >=x11-libs/gtk+-3.20:3[introspection]
+ )
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_configure() {
+ append-cppflags -DG_DISABLE_CAST_CHECKS
+
+ # On musl, it's required that either gjs, pixman or gnome-shell to be built
+ # with a larger stack otherwise librsvg fails to render a particular SVG, as
+ # a result we fail to get gdm or gnome-shell running (greeted with a fail
+ # whale screen). The bug has been reported to librsvg. This is ideally just
+ # a temporary workaround until we understand what exactly needs a larger
+ # stack size, as it's not sufficient to do just librsvg.
+ #
+ # Please refer to:
+ # https://gitlab.gnome.org/GNOME/librsvg/-/issues/686
+ # https://gitlab.gnome.org/GNOME/librsvg/-/issues/874
+ #
+ # TODO: Find an actual fix instead of increasing the stack
+ use elibc_musl && append-ldflags -Wl,-z,stack-size=2097152
+
+ # FIXME: add systemtap/dtrace support, like in glib:2
+ local emesonargs=(
+ $(meson_feature cairo)
+ $(meson_feature readline)
+ $(meson_feature sysprof profiler)
+ -Dinstalled_tests=false
+ $(meson_use !test skip_dbus_tests)
+ $(meson_use !test skip_gtk_tests)
+ -Db_pch=True # TODO this has to go
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}