summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-18 11:12:08 +0100
committerSam James <sam@gentoo.org>2023-10-18 11:12:08 +0100
commite0f0e1c28a7c48434188ca0f60ab21eafa8ba167 (patch)
treef4accc01b85e2190199ce2e77c413a704ac91c90
parentsys-boot/syslinux: drop binutils patch from 6.04_pre3 (diff)
downloadgentoo-e0f0e1c28a7c48434188ca0f60ab21eafa8ba167.tar.gz
gentoo-e0f0e1c28a7c48434188ca0f60ab21eafa8ba167.tar.bz2
gentoo-e0f0e1c28a7c48434188ca0f60ab21eafa8ba167.zip
sys-boot/syslinux: tweak binutils patch to support <2.39
This makes the upgrade path a bit easier and the option just suppresses a warning, not an error. Bug: https://bugs.gentoo.org/913129 Closes: https://bugs.gentoo.org/915663 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-boot/syslinux/files/syslinux-6.04-binutils-2.41.patch14
1 files changed, 7 insertions, 7 deletions
diff --git a/sys-boot/syslinux/files/syslinux-6.04-binutils-2.41.patch b/sys-boot/syslinux/files/syslinux-6.04-binutils-2.41.patch
index 530959fc478b..56762aa756d5 100644
--- a/sys-boot/syslinux/files/syslinux-6.04-binutils-2.41.patch
+++ b/sys-boot/syslinux/files/syslinux-6.04-binutils-2.41.patch
@@ -6,7 +6,7 @@ https://bugs.gentoo.org/913129
-fno-stack-check
ASFLAGS += $(ARCH3264)
-LDFLAGS += -nostdlib --warn-common --no-undefined --fatal-warnings
-+LDFLAGS += -nostdlib --warn-common --no-undefined --fatal-warnings --no-warn-rwx-segments -z notext
++LDFLAGS += -nostdlib --warn-common --no-undefined --fatal-warnings -z notext
--- a/gnu-efi/gnu-efi-3.0/apps/Makefile
+++ b/gnu-efi/gnu-efi-3.0/apps/Makefile
@@ -52,7 +52,7 @@ ifneq (,$(findstring FreeBSD,$(OS)))
@@ -14,7 +14,7 @@ https://bugs.gentoo.org/913129
endif
-LDFLAGS += -shared -Bsymbolic -L../lib -L../gnuefi $(CRTOBJS)
-+LDFLAGS += -shared --no-warn-rwx-segments -z notext -Bsymbolic -L../lib -L../gnuefi $(CRTOBJS)
++LDFLAGS += -shared -z notext -Bsymbolic -L../lib -L../gnuefi $(CRTOBJS)
LOADLIBES += -lefi -lgnuefi
LOADLIBES += $(shell $(CC) $(ARCH3264) -print-libgcc-file-name)
@@ -25,7 +25,7 @@ https://bugs.gentoo.org/913129
COM32LD = $(com32)/lib/$(ARCH)/elf.ld
-LDFLAGS = -m elf_$(ARCH) -shared --hash-style=gnu -T $(COM32LD)
-+LDFLAGS = -m elf_$(ARCH) -shared --no-warn-rwx-segments -z notext --hash-style=gnu -T $(COM32LD)
++LDFLAGS = -m elf_$(ARCH) -shared -z notext --hash-style=gnu -T $(COM32LD)
LIBGCC := $(shell $(CC) $(GCCOPT) --print-libgcc)
LNXCFLAGS = -I$(com32)/libutil/include $(GCCWARN) -O -g \
@@ -36,7 +36,7 @@ https://bugs.gentoo.org/913129
LDFLAGS = -T $(SRC)/$(ARCH)/syslinux.ld -Bsymbolic -pie -nostdlib -znocombreloc \
- -L$(LIBDIR) --hash-style=gnu -m elf_$(ARCH) $(CRT0) -E
-+ -L$(LIBDIR) --no-warn-rwx-segments -z notext --hash-style=gnu -m elf_$(ARCH) $(CRT0) -E
++ -L$(LIBDIR) -z notext --hash-style=gnu -m elf_$(ARCH) $(CRT0) -E
SFLAGS = $(GCCOPT) $(GCCWARN) $(ARCHOPT) \
-fomit-frame-pointer -D__COM32__ -D__FIRMWARE_$(FIRMWARE)__ \
@@ -47,7 +47,7 @@ https://bugs.gentoo.org/913129
SFLAGS = $(GCCOPT) -D__COM32__ -D__FIRMWARE_$(FIRMWARE)__
-LDFLAGS = -m elf_$(ARCH) -shared --hash-style=gnu -T $(com32)/lib/$(ARCH)/elf.ld --as-needed
-+LDFLAGS = -m elf_$(ARCH) -shared --no-warn-rwx-segments -z notext --hash-style=gnu -T $(com32)/lib/$(ARCH)/elf.ld --as-needed
++LDFLAGS = -m elf_$(ARCH) -shared -z notext --hash-style=gnu -T $(com32)/lib/$(ARCH)/elf.ld --as-needed
LIBGCC := $(shell $(CC) $(GCCOPT) --print-libgcc)
LNXCFLAGS = -I$(com32)/libutil/include -W -Wall -O -g -D_GNU_SOURCE
@@ -58,7 +58,7 @@ https://bugs.gentoo.org/913129
$(LIBMODULE_OBJS)
-LDFLAGS = -m elf_$(ARCH) --hash-style=gnu -T $(com32)/lib/$(ARCH)/elf.ld
-+LDFLAGS = -m elf_$(ARCH) --no-warn-rwx-segments -z notext --hash-style=gnu -T $(com32)/lib/$(ARCH)/elf.ld
++LDFLAGS = -m elf_$(ARCH) -z notext --hash-style=gnu -T $(com32)/lib/$(ARCH)/elf.ld
.SUFFIXES: .c .o .a .so .lo .i .S .s .ls .ss .lss
@@ -68,7 +68,7 @@ https://bugs.gentoo.org/913129
%.elf: %.o $(LIBDEP) $(LDSCRIPT) $(AUXLIBS)
$(LD) $(LDFLAGS) -pie -Bsymbolic \
-T $(LDSCRIPT) \
-+ --no-warn-rwx-segments -z notext \
++ -z notext \
--unresolved-symbols=report-all \
-E --hash-style=gnu -M -o $@ $< \
--start-group $(LIBS) $(subst $(*F).elf,lib$(*F).a,$@) --end-group \