summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-09 07:08:05 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-09 08:18:38 +0100
commite0f15dd07f1efc2e4e8080e782c1a1a6632b118a (patch)
treedc498a4ee65c72c1a47bf0fc79562a89dea2413b
parentdev-python/sqlglot: Bump to 22.3.0 (diff)
downloadgentoo-e0f15dd07f1efc2e4e8080e782c1a1a6632b118a.tar.gz
gentoo-e0f15dd07f1efc2e4e8080e782c1a1a6632b118a.tar.bz2
gentoo-e0f15dd07f1efc2e4e8080e782c1a1a6632b118a.zip
dev-python/bandit: Bump to 1.7.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/bandit/Manifest1
-rw-r--r--dev-python/bandit/bandit-1.7.8.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/bandit/Manifest b/dev-python/bandit/Manifest
index cae86cf30da4..e466948688c5 100644
--- a/dev-python/bandit/Manifest
+++ b/dev-python/bandit/Manifest
@@ -1 +1,2 @@
DIST bandit-1.7.7.tar.gz 1980358 BLAKE2B 78330ff515a5b8200a05615c8fbad0a65011ffd9c29cf40464fee372417982738de7fd616d1b5f8910dbe45937ba6da6a87252f471e7d762a905f4683d3892f0 SHA512 32682a9a4c54532be398444799bc6d46d06e2806d3e3e851dd09f0151b21df5974eaa4c940307f32cd6c58b36b99a361cbd8c48f189c27071565be6de63b0db5
+DIST bandit-1.7.8.tar.gz 1983678 BLAKE2B 7891c6f3cd893c0abd9becfb648284cbc393c5d0d1be6d9bf9934fcd33038ac34afd40e3d5cb4ef2d3389cb33f73d719de21cd9ef3acf8f64c73e41a11fc4fb6 SHA512 a9fb2e052018eaff77617f0b9aded2e42f2e50f8ff08d273597a686376e2f621f0f7be7efbb273380155a8bbf2aed4c7f15e48b5652544122d5b9766a4dc1cc1
diff --git a/dev-python/bandit/bandit-1.7.8.ebuild b/dev-python/bandit/bandit-1.7.8.ebuild
new file mode 100644
index 000000000000..13be010b92ac
--- /dev/null
+++ b/dev-python/bandit/bandit-1.7.8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A security linter from OpenStack Security"
+HOMEPAGE="
+ https://github.com/PyCQA/bandit/
+ https://pypi.org/project/bandit/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/GitPython-3.1.30[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/beautifulsoup4-4.8.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jschema-to-python-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/pylint-1.9.4[${PYTHON_USEDEP}]
+ >=dev-python/sarif-om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.3.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ ' 3.10)
+ )
+"
+
+distutils_enable_tests unittest