summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-09-30 05:50:17 +0200
committerHans de Graaff <graaff@gentoo.org>2021-09-30 05:50:55 +0200
commite0fbcaed927838432c76e67c2e5c2e35c086f51b (patch)
tree5234468d9e982fb696cfa2237cb7919eb17553b5
parentdev-lang/rust: mention than parallel-compiler flag is experimental (diff)
downloadgentoo-e0fbcaed.tar.gz
gentoo-e0fbcaed.tar.bz2
gentoo-e0fbcaed.zip
dev-ruby/serialport: add 1.3.2
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/serialport/Manifest1
-rw-r--r--dev-ruby/serialport/serialport-1.3.2.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/serialport/Manifest b/dev-ruby/serialport/Manifest
index 95cc0d03cd94..ac110dd5e8d4 100644
--- a/dev-ruby/serialport/Manifest
+++ b/dev-ruby/serialport/Manifest
@@ -1 +1,2 @@
DIST serialport-1.3.1.gem 25088 BLAKE2B 391188ff8a78f3998c82b17668a1aebad737643739c8087c4f32ce719dbf7bbf5f29cdc0717ab16f196020a227afc4fcfc29409331b2aabf5c6bf3382ef3496b SHA512 cdce9e13065cecf6d090d716626abb399bcc2a079be7bf1fe7755a20360218550f2f31980d62d8aae1fcc62fc62d6f7549685f865e30d2a5f40a617f5f197ed9
+DIST serialport-1.3.2.gem 25088 BLAKE2B 035e7bdb8ef321fb67ec63283c0e4c8fbf8f909ea3495994716b95cc55f212561a09a87352aed67290d96b54bb26b7802e5ed37c27e67291d768d7eb6d30850e SHA512 ff78fa04183108c2e9c5eb4f0caa9f8072a693a2a120ca084476b4125ca32ec67a6fb268bedda3ca142a9a397dbc585dffaab88f339fccc12e5ad03a09d4c28c
diff --git a/dev-ruby/serialport/serialport-1.3.2.ebuild b/dev-ruby/serialport/serialport-1.3.2.ebuild
new file mode 100644
index 000000000000..49a58625d129
--- /dev/null
+++ b/dev-ruby/serialport/serialport-1.3.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/native/extconf.rb)
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="a library for serial port (rs232) access in ruby"
+HOMEPAGE="https://github.com/hparra/ruby-serialport/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # Fix the miniterm script so that it might actually work, we'll
+ # install it as example.
+ sed -i -e 's:\.\./serialport.so:serialport:' test/miniterm.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ dodoc test/miniterm.rb
+}