summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-05-12 14:23:20 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-05-12 14:26:55 +0200
commite11807de4552f76940bdc488437013c02a0114dc (patch)
tree5ad7d8a10985e386b5f0c21d5c8d5bf25ed0d86f
parentgames-simulation/openrct2: update live ebuild (diff)
downloadgentoo-e11807de4552f76940bdc488437013c02a0114dc.tar.gz
gentoo-e11807de4552f76940bdc488437013c02a0114dc.tar.bz2
gentoo-e11807de4552f76940bdc488437013c02a0114dc.zip
games-simulation/openrct2: add 0.4.11
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--games-simulation/openrct2/Manifest1
-rw-r--r--games-simulation/openrct2/openrct2-0.4.11.ebuild180
2 files changed, 181 insertions, 0 deletions
diff --git a/games-simulation/openrct2/Manifest b/games-simulation/openrct2/Manifest
index ab483cd9245e..64e426e323b8 100644
--- a/games-simulation/openrct2/Manifest
+++ b/games-simulation/openrct2/Manifest
@@ -1,4 +1,5 @@
DIST openrct2-0.4.10.tar.gz 21854907 BLAKE2B 001918bf436be79a96b222971cdbb9118f26c5350c027360b749588c2112e8a12ae9aa435f6111dec1cb5c3f03d53560ca8b429c7ef0cccb4a5fe12eaf01c9ba SHA512 5ed9a6c790d5603fd1605669294a56908f493f347517d4c3bc8403df91b3678996d76980a42e9e3076b02fba598ee0bd33f2ad080762898cee7c40a865eed89d
+DIST openrct2-0.4.11.tar.gz 21842033 BLAKE2B 16647324f46aadd8b193dc703619836553e69c45b41a541b4c5670e37321c5ea5a6d9cf4a9ed1f669c25d9e9f178f28e806c9535e42a8be3d7212a1e92a4503e SHA512 820b0aaccdde433bf3da8a45e5893882e7a0bb1b0084fa6130ceab91489584a9d10b1ef18bac718e3f9ea910bdbcd878b7a3ca4f9361663a9fb496bb62a0ca80
DIST openrct2-0.4.9.tar.gz 21819673 BLAKE2B 32fa5b3a8a8e0b4a7031fcbca6ad419e5efe0812713d58d9e40880e3747671ca70ef6285536a335eba59aba41e3c9a238b55577796bd1c931b8e3c1fb99fff38 SHA512 711254007f8ed7377d6ceedcedf6e75d5a07033844dba891cc5c1f457d60a45ae4430d57f17624a5dce6d157d7ed269d235c53eedd46d58c433791d749953d85
DIST openrct2-objects-1.4.0.zip 5314707 BLAKE2B ae934f91f1de376851f37d37227049e90dcf644eab1bde4544b3a02ba1b678a3f27c49e106860db0f6817986301b95a1121be4827be06e05faf2c1b1583e953f SHA512 996cd4f6b5a3df1acd8258c68a123968e436b41e667e0d1f3a3e5b53d9f1788d1f8b3b87b4e8bbe3b1aff856449eca3bf04916e6a2bdca497e0de89807b90b3b
DIST openrct2-objects-1.4.3.zip 5391619 BLAKE2B 0e84f5b520c2c46503e3b1ea46ce6eebbc4960101b30405f7b29c3c8b2e76d45ff807e0a632b262a30a1d9f2acd11ed7870b81e0a3afd5357637ff946ef5a0e6 SHA512 cd5ac250f2e2ad89da1febc7d2f3486be0dd8ea442693b037f3f36b254a5216d9288fb17264c7821d5ec648571c6f5bb6c5f86c421c68f7913d1af0ccb290a3a
diff --git a/games-simulation/openrct2/openrct2-0.4.11.ebuild b/games-simulation/openrct2/openrct2-0.4.11.ebuild
new file mode 100644
index 000000000000..ab425de621d0
--- /dev/null
+++ b/games-simulation/openrct2/openrct2-0.4.11.ebuild
@@ -0,0 +1,180 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake readme.gentoo-r1 xdg-utils
+
+MY_PN="OpenRCT2"
+MY_PN_MSX="openmusic"
+MY_PN_OBJ="objects"
+MY_PN_RPL="replays"
+MY_PN_SFX="opensound"
+MY_PN_TS="title-sequences"
+MY_PV_MSX="1.5"
+MY_PV_OBJ="1.4.4"
+MY_PV_RPL="0.0.79"
+MY_PV_SFX="1.0.5"
+MY_PV_TS="0.4.6"
+
+DESCRIPTION="An open source re-implementation of Chris Sawyer's RollerCoaster Tycoon 2"
+HOMEPAGE="https://openrct2.org/"
+SRC_URI="
+ https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/${MY_PN}/${MY_PN_MSX}/releases/download/v${MY_PV_MSX}/${MY_PN_MSX}.zip -> ${PN}-${MY_PN_MSX}-${MY_PV_MSX}.zip
+ https://github.com/${MY_PN}/${MY_PN_OBJ}/releases/download/v${MY_PV_OBJ}/${MY_PN_OBJ}.zip -> ${PN}-${MY_PN_OBJ}-${MY_PV_OBJ}.zip
+ https://github.com/${MY_PN}/OpenSoundEffects/releases/download/v${MY_PV_SFX}/${MY_PN_SFX}.zip -> ${PN}-${MY_PN_SFX}-${MY_PV_SFX}.zip
+ https://github.com/${MY_PN}/${MY_PN_TS}/releases/download/v${MY_PV_TS}/${MY_PN_TS}.zip -> ${PN}-${MY_PN_TS}-${MY_PV_TS}.zip
+ test? ( https://github.com/${MY_PN}/${MY_PN_RPL}/releases/download/v${MY_PV_RPL}/${MY_PN_RPL}.zip -> ${PN}-${MY_PN_RPL}-${MY_PV_RPL}.zip )
+"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="dedicated +flac +opengl scripting test +truetype +vorbis"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ dev-libs/icu:=
+ dev-libs/jansson:=
+ dev-libs/libzip:=
+ media-libs/libpng:=
+ net-misc/curl[ssl]
+ sys-libs/zlib
+ !dedicated? (
+ media-libs/libsdl2
+ media-libs/speexdsp
+ flac? ( media-libs/flac:= )
+ opengl? ( virtual/opengl )
+ vorbis? ( media-libs/libvorbis )
+ )
+ dev-libs/openssl:0=
+ scripting? ( dev-lang/duktape:= )
+ truetype? (
+ media-libs/fontconfig:1.0
+ media-libs/freetype:2
+ )
+"
+
+RDEPEND="
+ ${COMMON_DEPEND}
+ dedicated? (
+ acct-group/openrct2
+ acct-user/openrct2
+ )
+"
+
+DEPEND="
+ ${COMMON_DEPEND}
+ dev-cpp/nlohmann_json
+ test? ( dev-cpp/gtest )
+"
+
+BDEPEND="
+ app-arch/unzip
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.4.0-include-additional-paths.patch"
+ "${FILESDIR}/${PN}-0.4.1-gtest-1.10.patch"
+)
+
+src_unpack() {
+ unpack "${P}".tar.gz
+
+ mkdir -p "${S}"/data || die
+ cd "${S}"/data
+ unpack "${PN}-${MY_PN_MSX}-${MY_PV_MSX}".zip
+ unpack "${PN}-${MY_PN_SFX}-${MY_PV_SFX}".zip
+
+ mkdir -p "${S}"/data/object || die
+ cd "${S}"/data/object || die
+ unpack "${PN}-${MY_PN_OBJ}-${MY_PV_OBJ}".zip
+
+ mkdir -p "${S}"/data/sequence || die
+ cd "${S}"/data/sequence || die
+ unpack "${PN}-${MY_PN_TS}-${MY_PV_TS}".zip
+
+ if use test; then
+ mkdir -p "${S}"/testdata/replays || die
+ cd "${S}"/testdata/replays || die
+ unpack "${PN}-${MY_PN_RPL}-${MY_PV_RPL}".zip
+ fi
+}
+
+src_prepare() {
+ cmake_src_prepare
+
+ # Don't treat warnings as errors.
+ sed -e 's/-Werror//' -i CMakeLists.txt || die
+}
+
+src_configure() {
+ # Note: There is currently no support for Disord-RPC and Google Benchmark,
+ # as both packages do not exist in Gentoo, so support for them has been disabled.
+ local mycmakeargs=(
+ -DDISABLE_DISCORD_RPC=ON
+ $(usex !dedicated "-DDISABLE_FLAC=$(usex !flac)" "")
+ -DDISABLE_GOOGLE_BENCHMARK=ON
+ -DDISABLE_GUI=$(usex dedicated)
+ -DDISABLE_HTTP=OFF
+ -DDISABLE_IPO=ON
+ -DDISABLE_NETWORK=OFF
+ $(usex !dedicated "-DDISABLE_OPENGL=$(usex !opengl)" "")
+ -DDISABLE_TTF=$(usex !truetype)
+ $(usex !dedicated "-DDISABLE_VORBIS=$(usex !vorbis)" "")
+ -DDOWNLOAD_OBJECTS=OFF
+ -DDOWNLOAD_OPENMSX=OFF
+ -DDOWNLOAD_OPENSFX=OFF
+ -DDOWNLOAD_REPLAYS=OFF
+ -DDOWNLOAD_TITLE_SEQUENCES=OFF
+ -DENABLE_SCRIPTING=$(usex scripting)
+ -DOPENRCT2_USE_CCACHE=OFF
+ -DPORTABLE=OFF
+ -DSTATIC=OFF
+ -DWITH_TESTS=$(usex test)
+ -DUSE_MMAP=ON
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ # Since the tests need the OpenRCT2 data,
+ # we need to symlink them into the build directory,
+ # otherwise some tests will fail, as they don't find the OpenRCT2 data.
+ # It is currently not possible to override that path.
+ # See: https://github.com/OpenRCT2/OpenRCT2/issues/6473
+ ln -s "${S}"/data "${BUILD_DIR}" || die
+
+ cmake_src_test
+}
+
+src_install() {
+ use scripting && DOCS+=( "distribution/scripting.md" "distribution/openrct2.d.ts" )
+
+ cmake_src_install
+
+ if use dedicated; then
+ newinitd "${FILESDIR}"/openrct2.initd openrct2
+ newconfd "${FILESDIR}"/openrct2.confd openrct2
+ fi
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}