summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-12-28 15:47:51 +0100
committerDavid Seifert <soap@gentoo.org>2020-12-28 15:47:51 +0100
commite125c1114ab32762846f27af587a8bdb22a985ef (patch)
treef579fb34ab94c177947d9906a18fad67b9435f79
parentapp-laptop/pommed: Port to EAPI 7 (diff)
downloadgentoo-e125c111.tar.gz
gentoo-e125c111.tar.bz2
gentoo-e125c111.zip
app-misc/vcp: Port to EAPI 7
Closes: https://bugs.gentoo.org/707464 Package-Manager: Portage-3.0.9, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--app-misc/vcp/files/vcp-2.2-fno-common.patch47
-rw-r--r--app-misc/vcp/vcp-2.2-r2.ebuild8
2 files changed, 52 insertions, 3 deletions
diff --git a/app-misc/vcp/files/vcp-2.2-fno-common.patch b/app-misc/vcp/files/vcp-2.2-fno-common.patch
new file mode 100644
index 000000000000..394cbaede850
--- /dev/null
+++ b/app-misc/vcp/files/vcp-2.2-fno-common.patch
@@ -0,0 +1,47 @@
+--- a/common.h
++++ b/common.h
+@@ -23,8 +23,8 @@
+ #define T_DIR 1 /* -> DIR */
+ #define T_NED 2 /* DIR -> NON-EXISTENT DIR */
+
+-WINDOW *mainw;
+-WINDOW *logw;
++extern WINDOW *mainw;
++extern WINDOW *logw;
+
+ struct dest_new {
+ char *opath;
+--- a/log.c
++++ b/log.c
+@@ -13,6 +13,8 @@
+ #include "screen.h"
+ #include "color.h"
+
++extern WINDOW *logw;
++
+ int logaddi(int code, char *base, int var, int var2) {
+
+ if(code == LOG_VRB && !vflag)
+--- a/misc.c
++++ b/misc.c
+@@ -22,6 +22,8 @@
+ #include "color.h"
+ #include "screen.h"
+
++extern WINDOW *logw;
++
+ int statit(char *path,struct stat *st,int cmdline) {
+ if(Rflag) {
+ if(pflag || ((Hflag) && !cmdline))
+--- a/screen.c
++++ b/screen.c
+@@ -17,6 +17,9 @@
+ int winw,winh,mainww;
+ int mainwsbw; /* width of status bar */
+
++WINDOW *mainw;
++WINDOW *logw;
++
+ /* create windows, draw border and title */
+ void scrn_draw() {
+ int dev_null;
diff --git a/app-misc/vcp/vcp-2.2-r2.ebuild b/app-misc/vcp/vcp-2.2-r2.ebuild
index c53cc103faa9..686e5ab2df44 100644
--- a/app-misc/vcp/vcp-2.2-r2.ebuild
+++ b/app-misc/vcp/vcp-2.2-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit flag-o-matic toolchain-funcs
@@ -17,8 +17,10 @@ DEPEND="sys-libs/ncurses:0="
RDEPEND="${DEPEND}"
DOCS=( Changelog README INSTALL )
+
PATCHES=(
- "${FILESDIR}"/${PN}-2.2-tinfo.patch
+ "${FILESDIR}"/${P}-tinfo.patch
+ "${FILESDIR}"/${P}-fno-common.patch
)
src_compile() {