summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2024-05-19 12:24:53 -0400
committerCraig Andrews <candrews@gentoo.org>2024-05-19 12:24:53 -0400
commite13d6f86bdf831d8be04443bcf72bf1c858072da (patch)
treeed6e89e87d9e3a01774ccb768550947451eef279
parentmail-client/roundcube: drop 1.5.2 (diff)
downloadgentoo-e13d6f86bdf831d8be04443bcf72bf1c858072da.tar.gz
gentoo-e13d6f86bdf831d8be04443bcf72bf1c858072da.tar.bz2
gentoo-e13d6f86bdf831d8be04443bcf72bf1c858072da.zip
mail-client/roundcube: drop 1.5.4
Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--mail-client/roundcube/Manifest1
-rw-r--r--mail-client/roundcube/roundcube-1.5.4.ebuild97
2 files changed, 0 insertions, 98 deletions
diff --git a/mail-client/roundcube/Manifest b/mail-client/roundcube/Manifest
index 6b14ed45f91f..3148fc2f6a46 100644
--- a/mail-client/roundcube/Manifest
+++ b/mail-client/roundcube/Manifest
@@ -1,4 +1,3 @@
-DIST roundcubemail-1.5.4-complete.tar.gz 7891674 BLAKE2B 898173304fb1a2618062f3cec1a156b64db893c3255f08de5eb1fb81bdd2b26bfe4939c45c1fe147d78d17be02787569919d4ae7724e22e1d10f8b2623bc4d39 SHA512 7205362dc93e24b97273e356f0e00c19f61e0241ed39b70e9a3b08e4798ea8bf494aa8822dcc26695f91cc67837fdbde54092aedc2b5a3e2701fe43e62950da8
DIST roundcubemail-1.5.5-complete.tar.gz 7891254 BLAKE2B d5aee913740c29e3d6381717c3b24c31ff71d056493bc9c1fd2cd067d683c3f254ec0f580ec2ae07589d6601672e04db4e9b0d7db3ce8451bb72f1cecae9ba7b SHA512 aa76a3024735ae27176823763977f75084806dd15de66beaca1bb1a93560c7127951bae4b4375a0d7e38dcb37bbeade5e78af23d2ff98aad09604c038fe7f872
DIST roundcubemail-1.5.6-complete.tar.gz 7891534 BLAKE2B 08d57f28026d9fbd06c531bb63e0eefdc02e848d3b22c87add93c5ed0a270facbbd31bf2a1fe7f8c54df0e5bcd8ff6c7180afe0117bfa88e45c33858c7339429 SHA512 7491dc62ca3e12d6be88b4d67fddecc837dc2ab5e46fe4d07b4936754eacf5967406b0ba882c034bd22fc3779d1cbd91c241dd48e6fab4e4206a4b25049c633e
DIST roundcubemail-1.6.4-complete.tar.gz 6027429 BLAKE2B f83ee7662dfa6a27e6aae97f90e1af80fa5d68927a0336dd3dab84f438e88921cb60059d41256daa52eac44fff07673559a21c860b01ebc82747fe021b2fadda SHA512 ccfd6828ed0f9a25c3144133a9a0f091b7ef76251e74422fe90dc1eb6fdddee8522902869d97609cd594f0977ecb6eb7402378d390ae33d907d154a24a607f85
diff --git a/mail-client/roundcube/roundcube-1.5.4.ebuild b/mail-client/roundcube/roundcube-1.5.4.ebuild
deleted file mode 100644
index 97463b150dea..000000000000
--- a/mail-client/roundcube/roundcube-1.5.4.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit webapp
-
-MY_PN=${PN}mail
-MY_PV=${PV/_/-}
-MY_P=${MY_PN}-${MY_PV}
-
-DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
-HOMEPAGE="https://roundcube.net"
-
-# roundcube is GPL-licensed, the rest of the licenses here are
-# for bundled PEAR components, googiespell and utf8.class.php
-LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"
-
-IUSE="change-password enigma exif fileinfo ldap mysql postgres sqlite ssl spell zip"
-REQUIRED_USE="|| ( mysql postgres sqlite )"
-
-# this function only sets DEPEND so we need to include that in RDEPEND
-need_httpd_cgi
-
-RDEPEND="
- ${DEPEND}
- >=dev-lang/php-8.0[exif?,fileinfo?,filter,gd,iconv,intl,json(+),ldap?,pdo,postgres?,session,sqlite?,ssl?,unicode,xml,zip?]
- virtual/httpd-php
- change-password? (
- dev-lang/php[sockets]
- )
- enigma? (
- app-crypt/gnupg
- )
- mysql? (
- || (
- dev-lang/php[mysql]
- dev-lang/php[mysqli]
- )
- )
- spell? ( dev-lang/php[curl,spell] )
-"
-
-if [[ ${PV} == *9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/roundcube/roundcubemail"
- EGIT_BRANCH="master"
- BDEPEND="${BDEPEND}
- app-arch/unzip
- dev-php/composer
- net-misc/curl"
-else
- SRC_URI="https://github.com/${PN}/${MY_PN}/releases/download/${MY_PV}/${MY_P}-complete.tar.gz"
- S="${WORKDIR}/${MY_P}"
- KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
-fi
-
-src_unpack() {
- if [[ "${PV}" == *9999* ]]; then
- git-r3_src_unpack
- pushd "${S}" > /dev/null || die
- rm Makefile || die
- mv composer.json-dist composer.json || die
- composer install --no-dev || die
- ./bin/install-jsdeps.sh || die
- popd > /dev/null || die
- else
- default
- fi
-}
-
-src_install() {
- webapp_src_preinst
-
- dodoc CHANGELOG.md INSTALL README.md UPGRADING SECURITY.md
-
- insinto "${MY_HTDOCSDIR}"
- doins -r [[:lower:]]* SQL
- doins .htaccess
-
- webapp_serverowned "${MY_HTDOCSDIR}"/logs
- webapp_serverowned "${MY_HTDOCSDIR}"/temp
-
- webapp_configfile "${MY_HTDOCSDIR}"/config/defaults.inc.php
- webapp_postupgrade_txt en "${FILESDIR}/POST-UPGRADE_complete.txt"
-
- webapp_src_install
-}
-
-pkg_postinst() {
- webapp_pkg_postinst
-
- if [[ -n ${REPLACING_VERSIONS} ]]; then
- elog "You can review the post-upgrade instructions at:"
- elog "${EROOT}/usr/share/webapps/${PN}/${PV}/postupgrade-en.txt"
- fi
-}