summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernardo Meurer <bernardo@standard.ai>2019-09-12 12:04:09 +0200
committerDavid Seifert <soap@gentoo.org>2019-09-12 12:04:09 +0200
commite13ecfddda536fbbe4b127a60c496eea7cbcfae6 (patch)
tree6827d5e95e62ecbc6f5723c6cf713c2a9bad978c
parentx11-drivers/nvidia-drivers: Old (diff)
downloadgentoo-e13ecfdd.tar.gz
gentoo-e13ecfdd.tar.bz2
gentoo-e13ecfdd.zip
dev-python/confuse: new package (1.0.0)
Confuse is a configuration library for Python that uses YAML. Closes: https://bugs.gentoo.org/693178 Closes: https://github.com/gentoo/gentoo/pull/12828 Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Bernardo Meurer <bernardo@standard.ai> Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-python/confuse/Manifest1
-rw-r--r--dev-python/confuse/confuse-1.0.0.ebuild42
-rw-r--r--dev-python/confuse/metadata.xml20
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/confuse/Manifest b/dev-python/confuse/Manifest
new file mode 100644
index 000000000000..d53a447c06e3
--- /dev/null
+++ b/dev-python/confuse/Manifest
@@ -0,0 +1 @@
+DIST confuse-1.0.0.tar.gz 34790 BLAKE2B efa23f59e6d450160af279042ed3d77b3b26bd1fe2fffd90b0ce1c87821b5540048b45644bfff1a8420007cf2a705d388965daa20034bb8f846085dd92b49186 SHA512 f436a400b9b84db1a20409c70d64fdde44903ffba6c3618917fd297e04ecf3dda806e315972f7cf1f786c93639b10b0652a622a579a2cfa47703386a43433c8d
diff --git a/dev-python/confuse/confuse-1.0.0.ebuild b/dev-python/confuse/confuse-1.0.0.ebuild
new file mode 100644
index 000000000000..716e4d492632
--- /dev/null
+++ b/dev-python/confuse/confuse-1.0.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Confuse is a configuration library for Python that uses YAML"
+HOMEPAGE="https://github.com/beetbox/confuse"
+SRC_URI="https://github.com/beetbox/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+DEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ rm -r docs/_build/html/_sources || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ nosetests -v || die "Tests failed"
+ if use doc; then
+ sphinx-build -W -q -b html docs __doctest || die "Doc tests failed"
+ fi
+}
diff --git a/dev-python/confuse/metadata.xml b/dev-python/confuse/metadata.xml
new file mode 100644
index 000000000000..b32d7cb6cb71
--- /dev/null
+++ b/dev-python/confuse/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bernardo@standard.ai</email>
+ <name>Bernardo Meurer</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Gentoo Proxy Maintainers Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Confuse is a configuration library for Python that uses YAML. It takes
+ care of defaults, overrides, type checking, command-line integration,
+ human-readable errors, and standard OS-specific locations.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">beetbox/confuse</remote-id>
+ </upstream>
+</pkgmetadata>