summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRandall T. Vasquez <ran.dall@icloud.com>2022-11-02 19:05:56 -0700
committerNicolas Bock <nicolasbock@gentoo.org>2023-02-20 11:11:27 -0700
commite1605578dc69e43fa6c2c155f645e103cf2fdb93 (patch)
tree8d25955479363b51c9f2a91d0bc0a6691ebb3aef
parentdev-libs/castxml: Fix wrong documentation path (diff)
downloadgentoo-e1605578.tar.gz
gentoo-e1605578.tar.bz2
gentoo-e1605578.zip
app-crypt/keybase: bump to 6.0.2, update ebuilds, new maintainer
Closes: https://github.com/gentoo/gentoo/pull/27373 Signed-off-by: Randall T. Vasquez <ran.dall@icloud.com> Signed-off-by: Nicolas Bock <nicolasbock@gentoo.org>
-rw-r--r--app-crypt/keybase/Manifest2
-rw-r--r--app-crypt/keybase/keybase-6.0.2.ebuild69
-rw-r--r--app-crypt/keybase/keybase-9999.ebuild69
-rw-r--r--app-crypt/keybase/metadata.xml19
4 files changed, 159 insertions, 0 deletions
diff --git a/app-crypt/keybase/Manifest b/app-crypt/keybase/Manifest
new file mode 100644
index 000000000000..55dcb4b87bc2
--- /dev/null
+++ b/app-crypt/keybase/Manifest
@@ -0,0 +1,2 @@
+DIST keybase-6.0.2-deps.tar.xz 202450984 BLAKE2B da3ec411dc06203da08bd472c9842258ad58de9caac9948a84c4a840f1503bb5959a2ce9ddfdec966c6c20a0729fb562666898d21c799fc8c263d6a8924c2fef SHA512 8c22eb2036987ccd131c0b68e126cecf8bf795d4e8366e1f9d2f07d947556094977e1066449dc82fb955f3f8773217822574d70675212d568fc0900f9127b6e6
+DIST keybase-6.0.2.tar.gz 57283593 BLAKE2B 272dd3c9e2e855e1979a620f5a600cb1352632fca055ba36140d2cc63013e8f8b7e66c5f9fe74ab2c71dac2df7cc27aac9a8387f7444eff4c469659ff1aece2e SHA512 0a3fe3f8b9fc7a3099696699268bec54aed898d0692a3033e54f816b87ef2616b83a0817d365b87a77ecb489ae5d11bae15597c3bcd23819422ec384ae63f6a0
diff --git a/app-crypt/keybase/keybase-6.0.2.ebuild b/app-crypt/keybase/keybase-6.0.2.ebuild
new file mode 100644
index 000000000000..a8dd68ddad93
--- /dev/null
+++ b/app-crypt/keybase/keybase-6.0.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module systemd
+
+DESCRIPTION="Keybase client"
+HOMEPAGE="https://keybase.io/"
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/keybase/client.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/keybase/client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI+=" https://dev.gentoo.org/~nicolasbock/${P}-deps.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="Apache-2.0 BSD BSD-2 LGPL-3 MIT MPL-2.0"
+SLOT="0"
+
+RDEPEND="
+ app-crypt/gnupg
+ sys-fs/fuse:0=
+"
+
+src_unpack() {
+ default
+ if [[ ${PV} == *9999 ]]; then
+ git-r3_src_unpack
+ GOMODCACHE="${S}/go/go-mod"
+ pushd "${S}/go" || die
+ ego mod download
+ popd || die
+ else
+ ln -vs "client-${PV}" "${P}" || die
+ mkdir -vp "${S}/src/github.com/keybase" || die
+ ln -vs "${S}" "${S}/src/github.com/keybase/client" || die
+ fi
+}
+
+src_compile() {
+ pushd go/keybase || die
+ ego build -tags production -o "${T}/keybase"
+ popd || die
+}
+
+src_test() {
+ pushd go/keybase || die
+ ego test
+ popd || die
+}
+
+src_install() {
+ dobin "${T}/keybase"
+ dobin "${S}/packaging/linux/run_keybase"
+ systemd_douserunit "${S}/packaging/linux/systemd/keybase.service"
+ insinto "/opt/keybase"
+ doins "${S}/packaging/linux/crypto_squirrel.txt"
+ dodir "/opt/keybase"
+}
+
+pkg_postinst() {
+ elog "Start/Restart keybase: run_keybase"
+ elog "Run the service: keybase service"
+ elog "Run the client: keybase login"
+ ewarn "Note that the user keybasehelper is obsolete and can be removed"
+}
diff --git a/app-crypt/keybase/keybase-9999.ebuild b/app-crypt/keybase/keybase-9999.ebuild
new file mode 100644
index 000000000000..a8dd68ddad93
--- /dev/null
+++ b/app-crypt/keybase/keybase-9999.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module systemd
+
+DESCRIPTION="Keybase client"
+HOMEPAGE="https://keybase.io/"
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/keybase/client.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/keybase/client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI+=" https://dev.gentoo.org/~nicolasbock/${P}-deps.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="Apache-2.0 BSD BSD-2 LGPL-3 MIT MPL-2.0"
+SLOT="0"
+
+RDEPEND="
+ app-crypt/gnupg
+ sys-fs/fuse:0=
+"
+
+src_unpack() {
+ default
+ if [[ ${PV} == *9999 ]]; then
+ git-r3_src_unpack
+ GOMODCACHE="${S}/go/go-mod"
+ pushd "${S}/go" || die
+ ego mod download
+ popd || die
+ else
+ ln -vs "client-${PV}" "${P}" || die
+ mkdir -vp "${S}/src/github.com/keybase" || die
+ ln -vs "${S}" "${S}/src/github.com/keybase/client" || die
+ fi
+}
+
+src_compile() {
+ pushd go/keybase || die
+ ego build -tags production -o "${T}/keybase"
+ popd || die
+}
+
+src_test() {
+ pushd go/keybase || die
+ ego test
+ popd || die
+}
+
+src_install() {
+ dobin "${T}/keybase"
+ dobin "${S}/packaging/linux/run_keybase"
+ systemd_douserunit "${S}/packaging/linux/systemd/keybase.service"
+ insinto "/opt/keybase"
+ doins "${S}/packaging/linux/crypto_squirrel.txt"
+ dodir "/opt/keybase"
+}
+
+pkg_postinst() {
+ elog "Start/Restart keybase: run_keybase"
+ elog "Run the service: keybase service"
+ elog "Run the client: keybase login"
+ ewarn "Note that the user keybasehelper is obsolete and can be removed"
+}
diff --git a/app-crypt/keybase/metadata.xml b/app-crypt/keybase/metadata.xml
new file mode 100644
index 000000000000..6c47b44141f7
--- /dev/null
+++ b/app-crypt/keybase/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>ran.dall@icloud.com</email>
+ <name>Randall T. Vasquez</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>nicolasbock@gentoo.org</email>
+ <name>Nicolas Bock</name>
+ </maintainer>
+ <longdescription lang="en">
+ The official Keybase secure messaging, file-sharing, and key directory
+ client for Linux.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">keybase/client</remote-id>
+ </upstream>
+</pkgmetadata>