summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-31 01:33:41 +0000
committerSam James <sam@gentoo.org>2021-10-31 01:33:41 +0000
commite1645d02e29cec605a91fd91b63543502e7599ac (patch)
tree02982c1eabc95cd43a55fd4b18e3120cf4dbc49f
parentsys-fs/e2fsprogs: run tests for non-native ABI in new merged -libs ebuild (diff)
downloadgentoo-e1645d02e29cec605a91fd91b63543502e7599ac.tar.gz
gentoo-e1645d02e29cec605a91fd91b63543502e7599ac.tar.bz2
gentoo-e1645d02e29cec605a91fd91b63543502e7599ac.zip
sys-fs/e2fsprogs: include dilfridge@'s changes to merged e2fsprogs-libs
From his overlay at https://gitweb.gentoo.org/dev/dilfridge.git/plain/sys-fs/e2fsprogs/e2fsprogs-1.46.3-r100.ebuild?id=8551292e0a0f847ab7072ffab9626a3003dca1ab. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.46.4-r50.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.46.4-r50.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.46.4-r50.ebuild
index 6eb62630726d..d646b58c2e6d 100644
--- a/sys-fs/e2fsprogs/e2fsprogs-1.46.4-r50.ebuild
+++ b/sys-fs/e2fsprogs/e2fsprogs-1.46.4-r50.ebuild
@@ -80,8 +80,6 @@ multilib_src_configure() {
$(tc-has-tls || echo --disable-tls)
$(multilib_native_use_enable fuse fuse2fs)
$(use_enable nls)
- --disable-libblkid
- --disable-libuuid
$(multilib_native_use_enable tools e2initrd-helper)
--disable-fsck
--disable-uuidd
@@ -92,14 +90,15 @@ multilib_src_configure() {
# we use blkid/uuid from util-linux now
if use kernel_linux ; then
export ac_cv_lib_{uuid_uuid_generate,blkid_blkid_get_cache}=yes
+ myeconfargs+=( --disable-lib{blkid,uuid} )
fi
ac_cv_path_LDCONFIG=: \
- ECONF_SOURCE="${S}" \
- CC="$(tc-getCC)" \
- BUILD_CC="$(tc-getBUILD_CC)" \
- BUILD_LD="$(tc-getBUILD_LD)" \
- econf "${myeconfargs[@]}"
+ ECONF_SOURCE="${S}" \
+ CC="$(tc-getCC)" \
+ BUILD_CC="$(tc-getBUILD_CC)" \
+ BUILD_LD="$(tc-getBUILD_LD)" \
+ econf "${myeconfargs[@]}"
if [[ ${CHOST} != *-uclibc ]] && grep -qs 'USE_INCLUDED_LIBINTL.*yes' config.{log,status} ; then
eerror "INTL sanity check failed, aborting build."