summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-11 08:55:09 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-11 10:01:41 +0200
commite171161b7b3b345da8f0ee553ffc99bedea4ad73 (patch)
treeea1ca26b9050d961d397a9ff368845dbcc71f840
parentdev-python/cython: Bump to 0.29.20 (diff)
downloadgentoo-e171161b7b3b345da8f0ee553ffc99bedea4ad73.tar.gz
gentoo-e171161b7b3b345da8f0ee553ffc99bedea4ad73.tar.bz2
gentoo-e171161b7b3b345da8f0ee553ffc99bedea4ad73.zip
dev-python/gevent: Bump to 20.6.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/gevent/Manifest1
-rw-r--r--dev-python/gevent/gevent-20.6.1.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/dev-python/gevent/Manifest b/dev-python/gevent/Manifest
index 6ee32d9d4840..335d85f61238 100644
--- a/dev-python/gevent/Manifest
+++ b/dev-python/gevent/Manifest
@@ -2,3 +2,4 @@ DIST gevent-1.4.0.tar.gz 5169595 BLAKE2B 0c78f67bc94d15419b8eadf8825d9657c6a7a82
DIST gevent-20.5.1.tar.gz 5566653 BLAKE2B 1d9a474681573ec2e9d3c0d40fbae8a91b8cfb80c3ff8b3cf0e119b0484458941224302afb59f16c3272e1d770b1c1e92a3f648754a81d2e894e35ed8a335c31 SHA512 c6f9360efa86e598b7b240cd15e24ee0711dc314bb14f8bcaee7b0768b34a0f090d66296819f4c2eb95fe1565fe1c0f3472fb47444c31cfebc348b420811aed5
DIST gevent-20.5.2.tar.gz 5567755 BLAKE2B 9cac45f92c7c1841cca4eb52a54f71406beb3e83136170610bba326a32722de3c5ebd3b777a45b73ab5e1012eb0dc49d861b042bab0c6194e61f44e6011ede2e SHA512 24f00a599f26d673947f0ed5582f8b55d1b214677578d7c5c2f8d8c106f89a98951db523597c470bcd788de9f6b7abcd3f25f7aff27788227f6d8c7ca7c183c1
DIST gevent-20.6.0.tar.gz 5803237 BLAKE2B 97b988964ef80fcc1c3238718b6802016fb46742c94e7e56b5196139181ff82ce60816e0a8ccc5c3e1c3b73ec11cc705884b5ac5524dbd5116dc0d8722ccc7a4 SHA512 28ee030934d3c379577c9f86b76838e5d76c7ea7c0880cdeac9dc5ead497ae0600fb02b2984c7312fd42319142200c674b75da2e93b58fd4a99882d601a95108
+DIST gevent-20.6.1.tar.gz 5806150 BLAKE2B fb75e440f31ad2952d1395780a66ee673c55e62b635a2c6757efe9706c404d126c38a613ac08cd088900c0b10913fe9ce9d57cec8a7cb252ae87912142cfafce SHA512 b7ceb5251b01972a11e3d51e1ebcaaca7c08d36b6ba7b138bee57f0d5da4553539a0ad538e8a433321bdac396788acbfb0ac294191e829df3f066d00816310bb
diff --git a/dev-python/gevent/gevent-20.6.1.ebuild b/dev-python/gevent/gevent-20.6.1.ebuild
new file mode 100644
index 000000000000..0ada47ba7720
--- /dev/null
+++ b/dev-python/gevent/gevent-20.6.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} )
+PYTHON_REQ_USE="ssl(+),threads(+)"
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Coroutine-based network library"
+HOMEPAGE="http://gevent.org/ https://pypi.org/project/gevent/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/libev-4.23:=
+ dev-libs/libuv:=
+ >=net-dns/c-ares-1.12:=
+ >=dev-python/greenlet-0.4.14
+ virtual/python-greenlet[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/futures[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ ' -2)
+ )"
+
+distutils_enable_sphinx doc
+
+# Tests take long and fail terribly a few times.
+# It also seems that they require network access.
+#RESTRICT="test"
+
+python_prepare_all() {
+ export LIBEV_EMBED="false"
+ export CARES_EMBED="false"
+ export EMBED="false"
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ append-flags -fno-strict-aliasing
+}
+
+python_test() {
+ cd src/gevent/tests || die
+ # TODO: figure out how to make them work and not hang
+# GEVENT_RESOLVER=ares \
+# "${EPYTHON}" -m gevent.tests \
+# -uall,-network \
+# --config known_failures.py \
+# --ignore tests_that_dont_use_resolver.txt || die
+# GEVENT_RESOLVER=dnspython \
+# "${EPYTHON}" -m gevent.tests \
+# -uall,-network \
+# --config known_failures.py \
+# --ignore tests_that_dont_use_resolver.txt || die
+# GEVENT_RESOLVER=thread \
+# "${EPYTHON}" -m gevent.tests \
+# --verbose \
+# -uall,-network \
+# --config known_failures.py \
+# --ignore tests_that_dont_use_resolver.txt || die
+ GEVENT_FILE=thread \
+ "${EPYTHON}" -m gevent.tests \
+ --verbose \
+ -uall,-network \
+ --config known_failures.py \
+ test__*subprocess*.py || die
+}
+
+python_install_all() {
+ local DOCS=( AUTHORS README.rst )
+ use examples && dodoc -r examples
+
+ distutils-r1_python_install_all
+}