summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-04-09 10:30:24 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-04-09 11:30:07 +0200
commite180dbaa23b73db6b7c5921c795af1726b1367dc (patch)
tree7fef77795f351ce383fcf6d6ef5ade0cd44ab850
parentapp-emacs/dap-mode: drop old 0.7_p20240406 (diff)
downloadgentoo-e180dbaa23b73db6b7c5921c795af1726b1367dc.tar.gz
gentoo-e180dbaa23b73db6b7c5921c795af1726b1367dc.tar.bz2
gentoo-e180dbaa23b73db6b7c5921c795af1726b1367dc.zip
app-emacs/lsp-ui: bump to 9.0.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/lsp-ui/Manifest1
-rw-r--r--app-emacs/lsp-ui/lsp-ui-9.0.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-emacs/lsp-ui/Manifest b/app-emacs/lsp-ui/Manifest
index 96e5d3e007d1..16d939a4ff45 100644
--- a/app-emacs/lsp-ui/Manifest
+++ b/app-emacs/lsp-ui/Manifest
@@ -1 +1,2 @@
DIST lsp-ui-8.0.1.tar.gz 5609941 BLAKE2B d62fd98d4c057cb6d994b94b4c488daef0fffe9d5a31627298f8e91f34a030e09574b960a078a6e6b596cbc4c52b682821b27bacb7957a0d3434dbad4c6ed47a SHA512 d0aa31ce2ae12d4d1b8979b2f3e7a08c3dcddb4c676d6fcca3e66005101eb59d0ea1f29ae07a2290f532cee1026be0a958263e4b64b89045c9164a669e208c61
+DIST lsp-ui-9.0.0.tar.gz 5610418 BLAKE2B b6dd07a20f04ddb296085b55a52a20fd5aaf2286f19a833855adf65094617e9f37874874e65f25e2709f5d3eb72b258fb27e93c2dc59cc8b23074341a241765d SHA512 3135168d60efde0a9ddef29e5fb7fd65bd641463ad4eab9da9e5ae2652d2735bf36abc75d8986c7100c127de490eb1af5e59f8299df18e5b3bb57150be2b1c51
diff --git a/app-emacs/lsp-ui/lsp-ui-9.0.0.ebuild b/app-emacs/lsp-ui/lsp-ui-9.0.0.ebuild
new file mode 100644
index 000000000000..546790e46d31
--- /dev/null
+++ b/app-emacs/lsp-ui/lsp-ui-9.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="UI modules for lsp-mode"
+HOMEPAGE="https://emacs-lsp.github.io/lsp-ui/
+ https://github.com/emacs-lsp/lsp-ui/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/emacs-lsp/${PN}.git"
+else
+ SRC_URI="https://github.com/emacs-lsp/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/dash
+ app-emacs/flycheck
+ app-emacs/lsp-mode
+ app-emacs/markdown-mode
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+ELISP_REMOVE="
+ Makefile
+"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"