summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-17 22:36:12 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-17 22:36:12 +0300
commite18c30bfb41aef07eeada42d311e0ef05fd67df4 (patch)
tree9b0d2e3d1805b4ed8b19c01fe3e121e524b65d38
parentdev-python/fastjsonschema: drop 2.15.3-r1 (diff)
downloadgentoo-e18c30bf.tar.gz
gentoo-e18c30bf.tar.bz2
gentoo-e18c30bf.zip
dev-python/pytest-asyncio: drop 0.18.3
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/pytest-asyncio/Manifest1
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.18.3.ebuild44
2 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/pytest-asyncio/Manifest b/dev-python/pytest-asyncio/Manifest
index 2681e081323d..60c03c8095d3 100644
--- a/dev-python/pytest-asyncio/Manifest
+++ b/dev-python/pytest-asyncio/Manifest
@@ -1,2 +1 @@
-DIST pytest-asyncio-0.18.3.tar.gz 25049 BLAKE2B 5439675fd03b7fdd4cd3dbf1f37daa83d6b18b199ccc7b54acc648187dffcf59154f8f0ec5d4144ed40554290343a0890952e67d4184b17b0a3817196592023e SHA512 04d2046c039131598cb593afc1908be0dff2b24a91c89f36fca75d2d65916571e48fe149c1ba90244f299586277320cf6f130a02824fde9ee0a4d2429bf58a54
DIST pytest-asyncio-0.19.0.gh.tar.gz 25754 BLAKE2B ee1e028021d7adaeef77e9dc9c1cc0d1a8fe5ee91777b2774d8f175e7520f7f1ae6d058d758964a052d2fc02d369a9dcb522edf8271b54b9b724555222592e29 SHA512 7be87e6edd28496713ae5cca396fed67d372f2882dd573a8b72a84ebf6d262060cda9372bcde601130c42fc27faf15cf292cd820995ea93a324c209f203e823f
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.18.3.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.18.3.ebuild
deleted file mode 100644
index 646385195afb..000000000000
--- a/dev-python/pytest-asyncio/pytest-asyncio-0.18.3.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 2019-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Library for testing asyncio code with pytest"
-HOMEPAGE="
- https://github.com/pytest-dev/pytest-asyncio/
- https://pypi.org/project/pytest-asyncio/
-"
-SRC_URI="
- https://github.com/pytest-dev/pytest-asyncio/archive/v${PV}.tar.gz
- -> ${P}.tar.gz
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- >=dev-python/pytest-5.4.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/flaky[${PYTHON_USEDEP}]
- >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-EPYTEST_DESELECT=(
- # rely on precise warning counts
- tests/modes/test_legacy_mode.py
- tests/trio/test_fixtures.py::test_strict_mode_ignores_trio_fixtures
-)