summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2017-09-01 21:43:01 +0200
committerMike Gilbert <floppym@gentoo.org>2017-09-02 11:52:04 -0400
commite190b75dd0eecf804e59c626a81568062b2f0a40 (patch)
treebfa8ac40341606f9d734de115aead739597ab22b
parentapp-i18n/fcitx-configtool: Version bump (0.4.9). (diff)
downloadgentoo-e190b75d.tar.gz
gentoo-e190b75d.tar.bz2
gentoo-e190b75d.zip
app-i18n/fcitx-configtool: Add live ebuild.
-rw-r--r--app-i18n/fcitx-configtool/fcitx-configtool-9999.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-i18n/fcitx-configtool/fcitx-configtool-9999.ebuild b/app-i18n/fcitx-configtool/fcitx-configtool-9999.ebuild
new file mode 100644
index 000000000000..85628cede8eb
--- /dev/null
+++ b/app-i18n/fcitx-configtool/fcitx-configtool-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/fcitx-configtool"
+fi
+
+DESCRIPTION="GTK+ GUI configuration tool for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-configtool"
+if [[ "${PV}" == "9999" ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.8
+ app-text/iso-codes
+ dev-libs/glib:2
+ x11-libs/gtk+:3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=()
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_GTK2=OFF
+ -DENABLE_GTK3=ON
+ )
+
+ cmake-utils_src_configure
+}