summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-09-29 13:11:08 +0200
committerPacho Ramos <pacho@gentoo.org>2023-09-29 13:30:25 +0200
commite19ffaeea332276ea2e4c7781fba34a40ebc5da2 (patch)
treefb6e971a3fd2d61f6adc3c01bc39643a28b46cc1
parentwww-client/firefox: add 115.3.1 (diff)
downloadgentoo-e19ffaee.tar.gz
gentoo-e19ffaee.tar.bz2
gentoo-e19ffaee.zip
gnome-extra/gnome-shell-extension-alphabetical-grid: add 35.0
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--gnome-extra/gnome-shell-extension-alphabetical-grid/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extension-alphabetical-grid/gnome-shell-extension-alphabetical-grid-35.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-alphabetical-grid/Manifest b/gnome-extra/gnome-shell-extension-alphabetical-grid/Manifest
index cc374032f863..fc6370780150 100644
--- a/gnome-extra/gnome-shell-extension-alphabetical-grid/Manifest
+++ b/gnome-extra/gnome-shell-extension-alphabetical-grid/Manifest
@@ -1,2 +1,3 @@
DIST gnome-shell-extension-alphabetical-grid-31.0.tar.gz 214302 BLAKE2B 16dcfdbd39e6e29f388af7a17e90069f9aa9aa22d03c22ab461053539686097d27238d6c4d5077e5cb7160bf15ed5717e132d34ba9407993af39e008b9b35efe SHA512 4639619ca43bacdc3c1658ac8fe4689ffed680c91b61f00ca2ba5ac929f246dd8726d88f628a0ebbe0fc85a616e7219d54c351e5f2773e765eb3ace6a3823944
DIST gnome-shell-extension-alphabetical-grid-32.0.tar.gz 214580 BLAKE2B b3fd0be85c5f74240f25a96b041df6ca0e3cf02b2b025eb2ffa5f1e3ed9f9562dac3ee37b7a32a548b3a8054ad8728a9d93c9bd84d771eadb0c9d56b2366cd97 SHA512 8ac96bea822df28cd980179a19d3f7acb8a950b3f1e41e650ff2982cb3b657434a0eb49357ebd206b68de102bb3c89b823f16cbcd379e7807598b923e5a64c6c
+DIST gnome-shell-extension-alphabetical-grid-35.0.tar.gz 215465 BLAKE2B 981bd47a47ab4c0b4d521a6d48164ae2edd2d883f38e37d3bda5f60eb75f0e3e27d607130e35d5a280593de2ab7955f29d8c0d76ca7bd5de33281a4d175a5d72 SHA512 af3641284361587adc6a8a8beefb95da8e35fbe2a505e7e21fd14afebb76175500745c4fe0b1bdbf0482a6c74c5facd6786aa59ec7f8cc2498b64f33aad255e7
diff --git a/gnome-extra/gnome-shell-extension-alphabetical-grid/gnome-shell-extension-alphabetical-grid-35.0.ebuild b/gnome-extra/gnome-shell-extension-alphabetical-grid/gnome-shell-extension-alphabetical-grid-35.0.ebuild
new file mode 100644
index 000000000000..3c2e00a566a1
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-alphabetical-grid/gnome-shell-extension-alphabetical-grid-35.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2-utils
+
+# Useful specially to prevent
+# https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/4684
+# https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/3180
+DESCRIPTION="Restore the alphabetical ordering of the app grid"
+HOMEPAGE="https://github.com/stuarthayhurst/alphabetical-grid-extension"
+SRC_URI="https://github.com/stuarthayhurst/alphabetical-grid-extension/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-45
+ gui-libs/libadwaita
+"
+DEPEND="${COMMON_DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/alphabetical-grid-extension-${PV}"
+extension_uuid="AlphabeticalAppGrid@stuarthayhurst"
+
+# Tests are only useful for upstream
+RESTRICT="test"
+
+# Not useful for us
+src_compile() { :; }
+
+src_install() {
+ einstalldocs
+ mv docs/icon.svg extension || die
+ cd extension || die
+ insinto /usr/share/glib-2.0/schemas
+ doins schemas/*.xml
+ rm -rf schemas || die
+ insinto /usr/share/gnome-shell/extensions/"${extension_uuid}"
+ doins -r *
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}