summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-08-02 11:24:01 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-08-02 11:24:01 +0200
commite1b399e69abadc3bb7463a4f910ca5fe35ee2388 (patch)
tree8df02dd447e0c09e5df2af21a8749ddcafc4aa92
parentapp-text/xindy: add dep on dev-texlive/texlive-fontsrecommended; bug #586190 (diff)
downloadgentoo-e1b399e6.tar.gz
gentoo-e1b399e6.tar.bz2
gentoo-e1b399e6.zip
dev-ml/ocaml-mysql: bump to 1.2.1
Package-Manager: portage-2.3.0
-rw-r--r--dev-ml/ocaml-mysql/Manifest1
-rw-r--r--dev-ml/ocaml-mysql/ocaml-mysql-1.2.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-ml/ocaml-mysql/Manifest b/dev-ml/ocaml-mysql/Manifest
index a969d16c1176..5589e837c9e4 100644
--- a/dev-ml/ocaml-mysql/Manifest
+++ b/dev-ml/ocaml-mysql/Manifest
@@ -1,2 +1,3 @@
DIST ocaml-mysql-1.1.1.tar.gz 119676 SHA256 f896fa101a05d81b85af8122fe1c2809008a5e5fdca00f9ceeb7eec356369e3a SHA512 a57e69bbde928aa15e4200cf08fe4504450ae95afbec96fab03412708986a628463acaadb1b66c8955baa0c8c8c5260ebeb2e961b907a056749c6546e006988f WHIRLPOOL dbc1ef77b1cb38002a852665561ff69234117d2c241a3d75769e7217b0e7fe40b7474be3da2781a9d28729c46274dab3d79a201b53320b4ce0140b2ea1492d5a
DIST ocaml-mysql-1.2.0.tar.gz 99236 SHA256 6eb2c218c9a16b3c92ba4e8ecb91dbf34ef221623a0f88c29eb84511dd0b9dff SHA512 d8a45e4df63648b8481faee40e614840044b4d4c41d704cead2bf66e794140908df23d1f960bac39a366dad8cba39797225f25ea598d46801f9a9f48c54eaae3 WHIRLPOOL cb4e9f695ac5ae1e7edc0f6b25f3f5c74597d1d2c598f2ab721a9f6868e036b9d3c247225d406eed6b35b8bc31c02f0a35292925f1a8208c99dc3cc5256b2bbb
+DIST ocaml-mysql-1.2.1.tar.gz 99250 SHA256 827a43e1341721eba5afe3acdec3d38bac87ff092918f529b0fc8c7df012ab1a SHA512 bf9b4a1bfcc1a8d356a2d74ea9d8de8dd201973b9dc89c06349e814c2368871f5f6ccc2eca25b33fa5fabf4b6d19a5b4b436a1e055b90468f16f575257121e64 WHIRLPOOL dbbb1a7acb0914c9ed829a12ddd58d0fee1e88d046bb624106b5e72abf932090d2da42cda9948a31183f1e01f8f8e10335520349fd2669a576622a4f1edff79a
diff --git a/dev-ml/ocaml-mysql/ocaml-mysql-1.2.1.ebuild b/dev-ml/ocaml-mysql/ocaml-mysql-1.2.1.ebuild
new file mode 100644
index 000000000000..70e513a31dc5
--- /dev/null
+++ b/dev-ml/ocaml-mysql/ocaml-mysql-1.2.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib eutils
+
+IUSE="+ocamlopt"
+
+DESCRIPTION="A package for ocaml that provides access to mysql databases"
+SRC_URI="http://ygrek.org.ua/p/release/ocaml-mysql/${P}.tar.gz"
+HOMEPAGE="http://ocaml-mysql.forge.ocamlcore.org/"
+
+DEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ sys-libs/zlib
+ >=virtual/mysql-4.0"
+
+RDEPEND="$DEPEND"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_compile()
+{
+ emake all
+ if use ocamlopt; then
+ emake opt
+ fi
+}
+
+src_install()
+{
+ findlib_src_preinst
+ emake install
+
+ dodoc CHANGES README VERSION || die
+}