summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-05 06:24:31 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-05 06:24:31 +0100
commite1b617120bef1753e90b0ff36886fa469c8ea2c1 (patch)
treebf88112b0bec37f44a7982e7b115091abba7d6b4
parentdev-python/wrapt: Bump to 1.16.0_rc2 (diff)
downloadgentoo-e1b617120bef1753e90b0ff36886fa469c8ea2c1.tar.gz
gentoo-e1b617120bef1753e90b0ff36886fa469c8ea2c1.tar.bz2
gentoo-e1b617120bef1753e90b0ff36886fa469c8ea2c1.zip
dev-python/starlette: Bump to 0.32.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/starlette/Manifest1
-rw-r--r--dev-python/starlette/starlette-0.32.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/starlette/Manifest b/dev-python/starlette/Manifest
index 6375f2f86a41..e213004d32cd 100644
--- a/dev-python/starlette/Manifest
+++ b/dev-python/starlette/Manifest
@@ -1 +1,2 @@
DIST starlette-0.31.1.gh.tar.gz 2846196 BLAKE2B 08ebe13d4b9716c6ff74a4f9ca6333f5e6dc31c6ce359b39cbf8e9822fad2e8c8a111788a37893ad687f4d3ffb3bef1e21146f3769b3ac07f083b1c454c07fa3 SHA512 8501b1f40fea9351eba8366dfe1adcb27d19a64a2f547153f3106f8d6828a47c850d6ffb634d6ce60e74fc02d510afda22bca33e07631b72f9a5558e977ea0f6
+DIST starlette-0.32.0.gh.tar.gz 2839571 BLAKE2B adf6b382b267f77309cea1914e980df3ec6e1a05c2ed535c9a26518581349523f9ef5b07c3b97af9123950a52b4ea43acd257527e00a83423b992ce93956b86e SHA512 4b655af29e0a2e031db4155e8697d23abee1e100735904a47b0989faf56a9a05c007a672e6576748849347aaab931c8c1ea89a09d77b04ac8b55a78284ab551a
diff --git a/dev-python/starlette/starlette-0.32.0.ebuild b/dev-python/starlette/starlette-0.32.0.ebuild
new file mode 100644
index 000000000000..5157f33105ee
--- /dev/null
+++ b/dev-python/starlette/starlette-0.32.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="The little ASGI framework that shines"
+HOMEPAGE="
+ https://www.starlette.io/
+ https://github.com/encode/starlette/
+ https://pypi.org/project/starlette/
+"
+# no docs or tests in sdist, as of 0.27.0
+SRC_URI="
+ https://github.com/encode/starlette/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/anyio-5[${PYTHON_USEDEP}]
+ >=dev-python/anyio-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.22.0[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/python-multipart[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/trio[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_IGNORE=(
+ # Unpackaged 'databases' dependency
+ tests/test_database.py
+)
+
+distutils_enable_tests pytest