summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-10-10 11:17:15 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-10-10 22:59:46 +0200
commite1baf09e284cd7af58889ee43990eddb4a0978bb (patch)
treebc107bf294bb3ec47d3bfaec3a4d6feb0777b933
parentdev-util/intel-graphics-compiler: add 1.0.12260.1 (diff)
downloadgentoo-e1baf09e284cd7af58889ee43990eddb4a0978bb.tar.gz
gentoo-e1baf09e284cd7af58889ee43990eddb4a0978bb.tar.bz2
gentoo-e1baf09e284cd7af58889ee43990eddb4a0978bb.zip
www-apps/sfpg: add 4.11.0
Bug: https://bugs.gentoo.org/876463 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--www-apps/sfpg/Manifest1
-rw-r--r--www-apps/sfpg/sfpg-4.11.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/www-apps/sfpg/Manifest b/www-apps/sfpg/Manifest
index c07796c625f7..29b697d78a7d 100644
--- a/www-apps/sfpg/Manifest
+++ b/www-apps/sfpg/Manifest
@@ -1 +1,2 @@
+DIST Single_File_PHP_Gallery_4.11.0.zip 46577 BLAKE2B f02a82d522a142c688363cf1a5491e35c9a10dcebfca6e426f16e0db95564563a52c5a267436c8e421aa151b183d2f8f64e6a1c3bbe7618f37536ddc64f10a96 SHA512 34fed2519d8f33dd8c72df4921ccb10ddbf8c98fc0640bd4aa1da7fc66bce2c3538de8f040a86a52f6be927897a350ca54a09b940eabf248d1a34a8f4203499d
DIST Single_File_PHP_Gallery_4.9.0.zip 43058 BLAKE2B 27eb6362f28b1d24d77d8e9ccfdf83814ca4de0c0e1a2d1a94345e6c4b0c5b95b223c2bf5186f64a83fae392d2f8bdf7eb4e77c5295a86b279ce0abc7cb625cf SHA512 511889ff9c8680dd49d5c982609508b73c9baa5a2d8f7e8f6642003ce9e9f1feec248d9da3c69a4363ddc7ef6c77652697c0fa30f51ba490c2c926428ac8482c
diff --git a/www-apps/sfpg/sfpg-4.11.0.ebuild b/www-apps/sfpg/sfpg-4.11.0.ebuild
new file mode 100644
index 000000000000..b57ac1408b7d
--- /dev/null
+++ b/www-apps/sfpg/sfpg-4.11.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+MY_PN="${PN^^}"
+MY_PV="fd8fa70739d18d786e88f7ffa57e250e0e41af8f"
+
+DESCRIPTION="A web gallery in one single PHP file"
+HOMEPAGE="https://sye.dk/sfpg/"
+SRC_URI="https://sye.dk/sfpg/Single_File_PHP_Gallery_${PV}.zip"
+S="${WORKDIR}"
+
+LICENSE="sfpg"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="bindist mirror"
+
+RDEPEND="
+ dev-lang/php[gd]
+ virtual/httpd-php
+"
+
+BDEPEND="app-arch/unzip"
+
+need_httpd_cgi
+
+DOCS=( "readme.txt" )
+
+src_install() {
+ webapp_src_preinst
+
+ einstalldocs
+
+ insinto "${MY_HTDOCSDIR}"
+ doins index.php
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+}