summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-01-30 08:09:46 +0100
committerFlorian Schmaus <flow@gentoo.org>2023-01-30 08:16:23 +0100
commite1dbc04410cba085c3587626744c8790d015da0a (patch)
tree4c1eb278bfa1570af43f14f83d78eabca0edebde
parentdev-python/pymdstat: Bump to 0.4.3 (diff)
downloadgentoo-e1dbc044.tar.gz
gentoo-e1dbc044.tar.bz2
gentoo-e1dbc044.zip
net-analyzer/wireshark: convert ewarn to readme.gentoo
As discussed with sam, the note about the pcap group does not really fit into the 'warning' category. It also causes noise since it is printed with every emerge of wireshark. So instead we use the readme.gentoo-r1 eclass now. Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--net-analyzer/wireshark/files/README.gentoo3
-rw-r--r--net-analyzer/wireshark/wireshark-4.0.3.ebuild8
2 files changed, 7 insertions, 4 deletions
diff --git a/net-analyzer/wireshark/files/README.gentoo b/net-analyzer/wireshark/files/README.gentoo
new file mode 100644
index 000000000000..a26d2c4dcb76
--- /dev/null
+++ b/net-analyzer/wireshark/files/README.gentoo
@@ -0,0 +1,3 @@
+NOTE: To capture traffic with wireshark as normal user you have to
+add yourself to the pcap group. This security measure ensures
+that only trusted users are allowed to sniff your traffic.
diff --git a/net-analyzer/wireshark/wireshark-4.0.3.ebuild b/net-analyzer/wireshark/wireshark-4.0.3.ebuild
index 38a3ce5e8814..ab3fdea34f32 100644
--- a/net-analyzer/wireshark/wireshark-4.0.3.ebuild
+++ b/net-analyzer/wireshark/wireshark-4.0.3.ebuild
@@ -6,7 +6,7 @@ EAPI=8
LUA_COMPAT=( lua5-{1..2} )
PYTHON_COMPAT=( python3_{9..10} )
-inherit fcaps flag-o-matic lua-single python-any-r1 qmake-utils xdg cmake
+inherit fcaps flag-o-matic readme.gentoo-r1 lua-single python-any-r1 qmake-utils xdg cmake
DESCRIPTION="A network protocol analyzer formerly known as ethereal"
HOMEPAGE="https://www.wireshark.org/"
@@ -292,6 +292,8 @@ src_install() {
if [[ -d "${ED}"/usr/share/appdata ]] ; then
rm -r "${ED}"/usr/share/appdata || die
fi
+
+ readme.gentoo_create_doc
}
pkg_postinst() {
@@ -306,7 +308,5 @@ pkg_postinst() {
"${EROOT}"/usr/bin/dumpcap
fi
- ewarn "NOTE: To capture traffic with wireshark as normal user you have to"
- ewarn "add yourself to the pcap group. This security measure ensures"
- ewarn "that only trusted users are allowed to sniff your traffic."
+ readme.gentoo_print_elog
}