summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2023-04-23 09:32:35 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2023-04-23 09:32:43 +0200
commite1e067cc2eb4a172d9dea350639588a5caa2cfbf (patch)
tree0709e93969caf8a7b9b4a53c77c08c7fadd25bbb
parentsec-keys/openpgp-keys-gentoo-developers: Stabilize 20230403 ALLARCHES, #904853 (diff)
downloadgentoo-e1e067cc.tar.gz
gentoo-e1e067cc.tar.bz2
gentoo-e1e067cc.zip
media-libs/libmtp: bump to 1.1.21
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
-rw-r--r--media-libs/libmtp/Manifest1
-rw-r--r--media-libs/libmtp/libmtp-1.1.21.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/media-libs/libmtp/Manifest b/media-libs/libmtp/Manifest
index 5c870218b38f..5755554a5331 100644
--- a/media-libs/libmtp/Manifest
+++ b/media-libs/libmtp/Manifest
@@ -1 +1,2 @@
DIST libmtp-1.1.20.tar.gz 860941 BLAKE2B f30dddf6fb2b4c17e7792412787f65d369f811741e64a77b781a50e70161f0047e53c7e9d9e70621f98482d6fd430c71bd46188df894ef76109c9cb3d9c02f19 SHA512 d0892909eb9b001b727690b991c7effd8c4b78054ba07d06e060979ff2fd78d0d6303d46906d3bc86e4edba6f8a8d3c970eb875372f572ed84019bc717f74018
+DIST libmtp-1.1.21.tar.gz 862703 BLAKE2B c6067d0e9c7e2410b950715d1f02243c835afacfb3eef2f250361d4075d378b2754dceadf5120c9a646413ea826f42291c530590861420f56140458558dccc8e SHA512 510f01f75de37a07c8ce54957a8fb74724538a7cfbdf1a86c201fda68573ef23fa578ff7baf2d9df938703b5776ded4ab1057c617125f3539e594bb5a1f3146f
diff --git a/media-libs/libmtp/libmtp-1.1.21.ebuild b/media-libs/libmtp/libmtp-1.1.21.ebuild
new file mode 100644
index 000000000000..8e8453ea4c9a
--- /dev/null
+++ b/media-libs/libmtp/libmtp-1.1.21.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit udev
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/${PN}/code"
+ inherit autotools git-r3
+else
+ inherit libtool
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Implementation of Microsoft's Media Transfer Protocol (MTP)"
+HOMEPAGE="http://libmtp.sourceforge.net/"
+
+LICENSE="LGPL-2.1" # LGPL-2+ and LGPL-2.1+ ?
+SLOT="0/9" # Based on SONAME of libmtp shared library
+IUSE="+crypt doc examples static-libs"
+
+RDEPEND="
+ acct-group/plugdev
+ virtual/libiconv
+ virtual/libusb:1
+ crypt? ( dev-libs/libgcrypt:0= )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+DOCS=( AUTHORS README TODO )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.1.19-fix-docdir.patch"
+)
+
+src_prepare() {
+ default
+
+ # ChangeLog says "RETIRING THIS FILE ..pause.. GIT" (Last entry from start of 2011)
+ rm ChangeLog || die
+
+ if [[ ${PV} == 9999* ]]; then
+ if [[ -e /usr/share/gettext/config.rpath ]]; then
+ cp /usr/share/gettext/config.rpath . || die
+ else
+ touch config.rpath || die # This is from upstream autogen.sh
+ fi
+ eautoreconf
+ else
+ # Needed to fix -fuse-ld=* filtering (e.g. lld)
+ # Can drop this once copyright year in libtool file included
+ # says >= 2021 (was 2014 at time of writing).
+ elibtoolize
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable crypt mtpz)
+ $(use_enable doc doxygen)
+ $(use_enable static-libs static)
+ --with-udev="$(get_udevdir)"
+ --with-udev-group=plugdev
+ --with-udev-mode=0660
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name "*.la" -delete || die
+
+ if use examples; then
+ docinto examples
+ dodoc examples/*.{c,h,sh}
+ fi
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}