summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-08 07:49:08 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-08 07:49:08 +0200
commite1f248b6fc469b6284cedcaf084a1dcf437b79ee (patch)
treedd405b884f93535db99ba3699567bef3c3bad4ba
parentdev-python/botocore: Bump to 1.21.37 (diff)
downloadgentoo-e1f248b6.tar.gz
gentoo-e1f248b6.tar.bz2
gentoo-e1f248b6.zip
dev-python/boto3: Bump to 1.18.37
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.18.37.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index f834554035fe..ac420e272a3e 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -3,4 +3,5 @@ DIST boto3-1.18.21.tar.gz 402611 BLAKE2B 39974c66ed5ad0697be6df04dbb141ce28e9a09
DIST boto3-1.18.28.tar.gz 406268 BLAKE2B 1379f65f46f287a541b098b3ae183bc7d0a6c40a58f6241d97ce39ffdde4f0655e755fe56890fda767b57c6cf7bd565d95745dbbeb80f42f729f561f6e8d9a82 SHA512 98c0d94dd4971f833677947dbfbdcd495a26fda60592130842cf2f22b8929c6f72f971294d9ddc4923372706bf7f37d3d4cb0ede32afc6955d8253c19ddab63f
DIST boto3-1.18.35.tar.gz 410165 BLAKE2B 1d32525175ee490b1b4029fc9c682afd789f850cff2fae4f3a46789b45c0cb3aa696e3b8f1c218e4efa1215c2945e21b9b00ea4cb0414addbecc593a858ada2d SHA512 d2ee1fa7465833696bb528119cce1629aba891e9cf85afd5a4757d2b900b8ed90d8fbc4fdb6aa69ee4d62cef8e7f13c2a078ad4135a5835739d455fef8ffcac0
DIST boto3-1.18.36.tar.gz 410432 BLAKE2B 08d73bb8d8f16040f62fa5fb5e40855e201cd3bc24e0ffd0fdebbbf69a4ec05a0a93a6e1f08a61cebb1661542eda9783c36c098e07fd9b2f0d3c6ecc0ece1aea SHA512 16cc41de99ee216991dcb42d4ad92b08a834efdeaeba1fb18edd68dc3c0d1d04bb25b858f15f68286308a9dba0b800fc9c392b6b807c562660431425351e89e5
+DIST boto3-1.18.37.tar.gz 411095 BLAKE2B fafa31a06c52b1f35290ab4e6af7eb6e0bf16704da57b959b61edb8e5621bc036b1723ab084653e1177cbef008f3b4728546b7dfe78d572f600eda681e8e3feb SHA512 8536652e95ba7affdf701f76ab4674f6fddcc1b123e3476dc272f582cde236dfd920459c6cd644465e638ea0d6abf982e2ef77320cf1e7a4f5f6ef8b01e36227
DIST boto3-1.18.7.tar.gz 395640 BLAKE2B 6a9fa1dd55644806fe93271805f35fbe0c4cb65d1de08dded2d2f57fcefa96e32c4ebe7b60743c52c0898222bc06d33dbd03d304bbef327b88022450a7943e2c SHA512 20e7fedab7d061ab02f391e9baf36cb554e7f194f38d24d5a75f76715b2acf1b51b6adce5d8cf5a2a0d29df73566db00b8813a219d45a194d9a8eb93d0dab570
diff --git a/dev-python/boto3/boto3-1.18.37.ebuild b/dev-python/boto3/boto3-1.18.37.ebuild
new file mode 100644
index 000000000000..819e73691110
--- /dev/null
+++ b/dev-python/boto3/boto3-1.18.37.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ ||
+ die "test failed under ${EPYTHON}"
+}