summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-14 22:59:19 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-14 23:03:38 +0200
commite1f70b563a59f5965ae0787046ffae9a3cb32d12 (patch)
tree3a1df1991b5d39a943b825917674fcb0826d1f87
parentdev-python/fasteners: Bump to 0.16.3 (diff)
downloadgentoo-e1f70b563a59f5965ae0787046ffae9a3cb32d12.tar.gz
gentoo-e1f70b563a59f5965ae0787046ffae9a3cb32d12.tar.bz2
gentoo-e1f70b563a59f5965ae0787046ffae9a3cb32d12.zip
dev-python/apispec: Bump to 4.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/apispec/Manifest1
-rw-r--r--dev-python/apispec/apispec-4.6.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/apispec/Manifest b/dev-python/apispec/Manifest
index 59621915accf..ab26684b9e7f 100644
--- a/dev-python/apispec/Manifest
+++ b/dev-python/apispec/Manifest
@@ -1,3 +1,4 @@
DIST apispec-4.4.1.tar.gz 64424 BLAKE2B b46390659334f5ce5aa83fd15207f5d1ad6d0e9c530f9e7d2b1a0f6a787498aad065153cde9237ce1ab408256e5cd698bbc674dc0316eb4ed16b874ce34611c4 SHA512 fea0787598ca93711eaa231675f97623eb3d6eb224e11c40e66857b95f48724618bf7a9bfda476b56c1c96fe70bb61675966b1f3fb073fe3f7e4da91e78d3d90
DIST apispec-4.4.2.tar.gz 64660 BLAKE2B 1e53d4b3f8856e76565690773085dfcbaaab4e1771186eb8ea35f469d7c65b8d5bd6319af0ee32539de96ce5ff1889a15d74ac764d7bb9d0b415648af87d28db SHA512 8f8070ec1a084e5c5dda02d30103ff25a2fe096839aa2b1a75858297377e312e29a2d1cf4d373a53b7bffcbe9108489c2a2516e0e053c2de12ef90044b6b7e17
DIST apispec-4.5.0.tar.gz 65423 BLAKE2B ce6cc6f466d274db6aa5f8b27c3a9340daff7934b9293c501b5305b4a6ccbd22e8b12a163e20e5e02d571a8177adb6d5b3196ffa46ae68f2931b6c3ced2b4d0c SHA512 0abb186182513a6d7e4aeeeb80cd8976eebe7c40932ca7c53cd8be149e65a768235436382bab2006a79bcdf345cde55fd69eb3f28f8d14cde5fe064f7c7a76ad
+DIST apispec-4.6.0.tar.gz 66147 BLAKE2B 98127cb2bf938cc1928e13e1169804eea174351a0f4eeaabc801da711d0861bc35a9761e9f1bc478a44d6a85989a1aba1840b3e472599064240a880fda8e45b4 SHA512 b030e5400a9abce06576406f83befb298814617e06729f29c2ee70517cf456901b67e60880b3b4baec096717a91341e8268bcd8e01fd566b7c6e03709afd7c3b
diff --git a/dev-python/apispec/apispec-4.6.0.ebuild b/dev-python/apispec/apispec-4.6.0.ebuild
new file mode 100644
index 000000000000..3db198fe80a0
--- /dev/null
+++ b/dev-python/apispec/apispec-4.6.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pluggable API specification generator."
+HOMEPAGE="https://github.com/marshmallow-code/apispec/"
+SRC_URI="https://github.com/marshmallow-code/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-python/bottle[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/marshmallow[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-issues \
+ dev-python/sphinx_rtd_theme
+
+python_test() {
+ local deselect=(
+ # requires unpackaged prance
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v2
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v3
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}