summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-03 01:18:22 +0000
committerSam James <sam@gentoo.org>2022-01-03 01:19:14 +0000
commite1f7fc1b141be3d636b4c7d3fef203cc0bc96dea (patch)
tree3856d3a5498bf36b78b55d0dd6e19387dcf5ce7f
parentdev-lisp/asdf: update EAPI 6 -> 7 (diff)
downloadgentoo-e1f7fc1b.tar.gz
gentoo-e1f7fc1b.tar.bz2
gentoo-e1f7fc1b.zip
app-misc/rlwrap: use autotools.eclass, not manual autoreconf
Vanilla autoreconf won't benefit from error handling or the other magic the eclass does for us. Also add a missing ncurses dependency. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-misc/rlwrap/rlwrap-0.45.2-r1.ebuild (renamed from app-misc/rlwrap/rlwrap-0.45.2.ebuild)10
1 files changed, 7 insertions, 3 deletions
diff --git a/app-misc/rlwrap/rlwrap-0.45.2.ebuild b/app-misc/rlwrap/rlwrap-0.45.2-r1.ebuild
index 8a0f63a892b2..c981173038ec 100644
--- a/app-misc/rlwrap/rlwrap-0.45.2.ebuild
+++ b/app-misc/rlwrap/rlwrap-0.45.2-r1.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+inherit autotools
+
DESCRIPTION="GNU readline wrapper"
HOMEPAGE="https://github.com/hanslub42/rlwrap"
SRC_URI="https://github.com/hanslub42/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
@@ -12,12 +14,14 @@ SLOT="0"
KEYWORDS="~amd64 ~arm64 ~mips ~ppc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
IUSE="debug"
-RDEPEND="sys-libs/readline:0="
+RDEPEND="sys-libs/ncurses:=
+ sys-libs/readline:="
DEPEND="${RDEPEND}"
src_prepare() {
default
- autoreconf --install
+
+ eautoreconf
}
src_configure() {