summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-09 09:34:16 +0100
committerSam James <sam@gentoo.org>2023-06-09 09:34:16 +0100
commite1f93f9835116aa85a579a955a806d777adfcb49 (patch)
tree52e975be3d20e44f40db6a9b012cf8da79e612ec
parentsys-apps/coreutils: backport fix for old kernels + copy_file_range (diff)
downloadgentoo-e1f93f9835116aa85a579a955a806d777adfcb49.tar.gz
gentoo-e1f93f9835116aa85a579a955a806d777adfcb49.tar.bz2
gentoo-e1f93f9835116aa85a579a955a806d777adfcb49.zip
sys-libs/freeipmi: drop 1.6.9, 1.6.10
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-libs/freeipmi/Manifest1
-rw-r--r--sys-libs/freeipmi/freeipmi-1.6.10.ebuild97
-rw-r--r--sys-libs/freeipmi/freeipmi-1.6.9.ebuild93
3 files changed, 0 insertions, 191 deletions
diff --git a/sys-libs/freeipmi/Manifest b/sys-libs/freeipmi/Manifest
index 783da5aa35eb..ec6938a0c85e 100644
--- a/sys-libs/freeipmi/Manifest
+++ b/sys-libs/freeipmi/Manifest
@@ -1,2 +1 @@
DIST freeipmi-1.6.10.tar.gz 3431062 BLAKE2B e217570d8fcf78ca9d04aad4d5bd46b4120beb21f2dcfb083bc9779a4541856e08ec6e87549651ee3c9b62fe54521585e192c784254dd9482bf9da09935853ae SHA512 90b6b78cdd119c2a1f332f007333aa6df70c6e3de0fd81ab007025392ee7cb7a01ab4a7a174d1f2e760c55d78f21ebbbe9667af661ccdd669e4b54edb1346937
-DIST freeipmi-1.6.9.tar.gz 3429566 BLAKE2B 68ee7bd27d459a25464e17d9c98370252d33961d10e69675505f046db26a95d780c114b4f90eeab43a39d0fca3d98b1f108c6d3ca9550fd9d3c455d2e9a79c6b SHA512 536add8dc01aa4d9df45e3499f8be1318185b19beb579c8f991a11ca973626d7e0aabe1d8760a9addadc418ea5c1e2b5432053e46ba94fd9078fb6dcabf48280
diff --git a/sys-libs/freeipmi/freeipmi-1.6.10.ebuild b/sys-libs/freeipmi/freeipmi-1.6.10.ebuild
deleted file mode 100644
index 2b1cc92c5ba9..000000000000
--- a/sys-libs/freeipmi/freeipmi-1.6.10.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs
-
-AT_M4DIR="config"
-
-DESCRIPTION="Provides Remote-Console and System Management Software as per IPMI v1.5/2.0"
-HOMEPAGE="https://www.gnu.org/software/freeipmi/"
-
-MY_P="${P/_/.}"
-[[ ${MY_P} == *.beta* ]] && ALPHA="-alpha"
-SRC_URI="mirror://gnu${ALPHA}/${PN}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc64 ~x86"
-IUSE="debug nagios without-root"
-
-RDEPEND="dev-libs/libgcrypt:0="
-DEPEND="${RDEPEND}
- virtual/os-headers"
-RDEPEND="${RDEPEND}
- nagios? (
- || ( net-analyzer/icinga net-analyzer/nagios )
- dev-lang/perl
- )
-"
-
-src_configure() {
- local myeconfargs=(
- $(use_enable debug)
- $(usex without-root --with-dont-check-for-root "")
- --disable-static
- --disable-init-scripts
- --localstatedir="${EPREFIX}"/var
- ac_cv_path_CPP_FOR_BUILD="$(tc-getPROG CPP cpp)"
- )
-
- econf "${myeconfargs[@]}"
-}
-
-# There are no tests
-src_test() { :; }
-
-src_install() {
- default
-
- # freeipmi by defaults install _all_ commands to /usr/sbin, but
- # quite a few can be run remotely as standard user, so move them
- # in /usr/bin afterwards.
- dodir /usr/bin
- local prog
- for prog in ipmi{detect,ping,power,console}; do
- mv "${ED}"/usr/{s,}bin/${prog} || die
-
- # The default install symlinks these commands to add a dash
- # after the ipmi prefix; we repeat those after move for
- # consistency.
- rm "${ED}"/usr/sbin/${prog/ipmi/ipmi-}
- dosym ${prog} /usr/bin/${prog/ipmi/ipmi-}
- done
-
- # Install the nagios plugin in its proper place, if desired
- if use nagios; then
- dodir /usr/$(get_libdir)/nagios/plugins
- mv "${ED}"/usr/share/doc/${PF}/contrib/nagios/nagios_ipmi_sensors.pl \
- "${ED}"/usr/$(get_libdir)/nagios/plugins/ || die
- fperms 0755 /usr/$(get_libdir)/nagios/plugins/nagios_ipmi_sensors.pl
-
- insinto /etc/icinga/conf.d
- newins "${FILESDIR}"/freeipmi.icinga freeipmi-command.cfg
- fi
-
- dodoc AUTHORS ChangeLog* DISCLAIMER* NEWS README* TODO doc/*.txt
-
- keepdir \
- /var/cache/ipmiseld \
- /var/cache/ipmimonitoringsdrcache \
- /var/lib/freeipmi \
- /var/log/ipmiconsole
-
- # starting from version 1.2.0 the two daemons are similar enough
- newinitd "${FILESDIR}"/bmc-watchdog.initd.4 ipmidetectd
- newconfd "${FILESDIR}"/ipmidetectd.confd ipmidetectd
-
- newinitd "${FILESDIR}"/bmc-watchdog.initd.4 bmc-watchdog
- newconfd "${FILESDIR}"/bmc-watchdog.confd bmc-watchdog
-
- newinitd "${FILESDIR}"/bmc-watchdog.initd.4 ipmiseld
- newconfd "${FILESDIR}"/ipmiseld.confd ipmiseld
-
- find "${ED}" -type f -name "*.la" -delete || die
-}
diff --git a/sys-libs/freeipmi/freeipmi-1.6.9.ebuild b/sys-libs/freeipmi/freeipmi-1.6.9.ebuild
deleted file mode 100644
index b84a6b5775e5..000000000000
--- a/sys-libs/freeipmi/freeipmi-1.6.9.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-AT_M4DIR="config"
-
-DESCRIPTION="Provides Remote-Console and System Management Software as per IPMI v1.5/2.0"
-HOMEPAGE="https://www.gnu.org/software/freeipmi/"
-
-MY_P="${P/_/.}"
-S="${WORKDIR}/${MY_P}"
-[[ ${MY_P} == *.beta* ]] && ALPHA="-alpha"
-SRC_URI="mirror://gnu${ALPHA}/${PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 hppa ~ppc64 x86"
-IUSE="debug nagios"
-
-RDEPEND="dev-libs/libgcrypt:0="
-DEPEND="${RDEPEND}
- virtual/os-headers"
-RDEPEND="${RDEPEND}
- nagios? (
- || ( net-analyzer/icinga net-analyzer/nagios )
- dev-lang/perl
- )
-"
-
-src_configure() {
- local myeconfargs=(
- $(use_enable debug)
- --disable-static
- --disable-init-scripts
- --localstatedir="${EPREFIX}"/var
- )
-
- econf "${myeconfargs[@]}"
-}
-
-# There are no tests
-src_test() { :; }
-
-src_install() {
- default
-
- # freeipmi by defaults install _all_ commands to /usr/sbin, but
- # quite a few can be run remotely as standard user, so move them
- # in /usr/bin afterwards.
- dodir /usr/bin
- local prog
- for prog in ipmi{detect,ping,power,console}; do
- mv "${ED}"/usr/{s,}bin/${prog} || die
-
- # The default install symlinks these commands to add a dash
- # after the ipmi prefix; we repeat those after move for
- # consistency.
- rm "${ED}"/usr/sbin/${prog/ipmi/ipmi-}
- dosym ${prog} /usr/bin/${prog/ipmi/ipmi-}
- done
-
- # Install the nagios plugin in its proper place, if desired
- if use nagios; then
- dodir /usr/$(get_libdir)/nagios/plugins
- mv "${ED}"/usr/share/doc/${PF}/contrib/nagios/nagios_ipmi_sensors.pl \
- "${ED}"/usr/$(get_libdir)/nagios/plugins/ || die
- fperms 0755 /usr/$(get_libdir)/nagios/plugins/nagios_ipmi_sensors.pl
-
- insinto /etc/icinga/conf.d
- newins "${FILESDIR}"/freeipmi.icinga freeipmi-command.cfg
- fi
-
- dodoc AUTHORS ChangeLog* DISCLAIMER* NEWS README* TODO doc/*.txt
-
- keepdir \
- /var/cache/ipmiseld \
- /var/cache/ipmimonitoringsdrcache \
- /var/lib/freeipmi \
- /var/log/ipmiconsole
-
- # starting from version 1.2.0 the two daemons are similar enough
- newinitd "${FILESDIR}"/bmc-watchdog.initd.4 ipmidetectd
- newconfd "${FILESDIR}"/ipmidetectd.confd ipmidetectd
-
- newinitd "${FILESDIR}"/bmc-watchdog.initd.4 bmc-watchdog
- newconfd "${FILESDIR}"/bmc-watchdog.confd bmc-watchdog
-
- newinitd "${FILESDIR}"/bmc-watchdog.initd.4 ipmiseld
- newconfd "${FILESDIR}"/ipmiseld.confd ipmiseld
-
- find "${ED}" -type f -name "*.la" -delete || die
-}