summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-01 22:52:44 +0000
committerSam James <sam@gentoo.org>2021-04-01 23:03:58 +0000
commite202861b974e5e3b5870a02f99e2b7337dac219f (patch)
tree82b9addeecf8bd3e00cf3b5498ad114e0c3d7e2c
parentmedia-libs/libsdl: fix (parallel) build with slibtool (diff)
downloadgentoo-e202861b.tar.gz
gentoo-e202861b.tar.bz2
gentoo-e202861b.zip
media-gfx/gtkimageview: port to EAPI 7, BDEPEND
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-gfx/gtkimageview/gtkimageview-1.6.4.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/media-gfx/gtkimageview/gtkimageview-1.6.4.ebuild b/media-gfx/gtkimageview/gtkimageview-1.6.4.ebuild
index 707ce5975732..2e38da6bfd9b 100644
--- a/media-gfx/gtkimageview/gtkimageview-1.6.4.ebuild
+++ b/media-gfx/gtkimageview/gtkimageview-1.6.4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-GNOME2_LA_PUNT="yes"
+EAPI=7
+GNOME2_LA_PUNT="yes"
inherit autotools gnome2
DESCRIPTION="A simple image viewer widget for GTK"
@@ -19,9 +19,10 @@ IUSE="examples static-libs"
RESTRICT="test"
RDEPEND="x11-libs/gtk+:2"
-DEPEND="${RDEPEND}
- gnome-base/gnome-common
+DEPEND="gnome-base/gnome-common"
+BDEPEND="
dev-util/gtk-doc-am
+ gnome-base/gnome-common
"
src_prepare() {
@@ -47,6 +48,7 @@ src_configure() {
src_install() {
gnome2_src_install
+
if use examples ; then
docinto examples
dodoc tests/ex-*.c