summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2022-06-29 11:32:55 -0400
committerMike Gilbert <floppym@gentoo.org>2022-06-29 15:44:34 -0400
commite227bcf7752f4e1389bfb61373136a1956632eb2 (patch)
treec4231cb2c0fc8ff02e28f5db7e7a323495de1a70
parentmedia-libs/mesa: Version bump to 22.1.3 (diff)
downloadgentoo-e227bcf7.tar.gz
gentoo-e227bcf7.tar.bz2
gentoo-e227bcf7.zip
sys-devel/gettext: pass JAVACFLAGS in JAVAC variable
Also avoid building java classes multiple times when muiltilib is enabled. Bug: https://bugs.gentoo.org/770508 Closes: https://bugs.gentoo.org/855134 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--sys-devel/gettext/gettext-0.21-r1.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sys-devel/gettext/gettext-0.21-r1.ebuild b/sys-devel/gettext/gettext-0.21-r1.ebuild
index dffca52da8a5..d8788c77d071 100644
--- a/sys-devel/gettext/gettext-0.21-r1.ebuild
+++ b/sys-devel/gettext/gettext-0.21-r1.ebuild
@@ -108,7 +108,7 @@ multilib_src_configure() {
$(use_enable cxx libasprintf)
$(use_with git)
$(usex git --without-cvs $(use_with cvs))
- $(use_enable java)
+ $(multilib_native_use_enable java)
$(use_enable ncurses curses)
$(use_enable nls)
$(use_enable openmp)
@@ -121,6 +121,11 @@ multilib_src_configure() {
ECONF_SOURCE+=/gettext-runtime
fi
+ # Ensure javacomp.sh uses our desired source and target versions.
+ # https://bugs.gentoo.org/855134
+ local -x JAVAC="${JAVAC} ${JAVACFLAGS}"
+ export JAVA_VERBOSE=1
+
econf "${myconf[@]}"
}