summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-17 22:34:27 +0100
committerSam James <sam@gentoo.org>2021-08-17 22:39:08 +0100
commite255819ea5906b4b22d09faa283e99f9a984c60c (patch)
tree13fd8eee93ba1359e0a01da790e5840fcdd5e31e
parentgames-strategy/warzone2100: don't compress man pages, fix applying patches (diff)
downloadgentoo-e255819ea5906b4b22d09faa283e99f9a984c60c.tar.gz
gentoo-e255819ea5906b4b22d09faa283e99f9a984c60c.tar.bz2
gentoo-e255819ea5906b4b22d09faa283e99f9a984c60c.zip
dev-vcs/git: drop Python 3.7, add subslot dep on libpcre2
Python 3.7 support is gone from the eclasses, so it's a noop. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-vcs/git/git-2.32.0-r1.ebuild (renamed from dev-vcs/git/git-2.32.0.ebuild)4
-rw-r--r--dev-vcs/git/git-2.33.0-r1.ebuild (renamed from dev-vcs/git/git-2.33.0.ebuild)4
-rw-r--r--dev-vcs/git/git-9999-r1.ebuild4
-rw-r--r--dev-vcs/git/git-9999-r2.ebuild4
-rw-r--r--dev-vcs/git/git-9999-r3.ebuild4
-rw-r--r--dev-vcs/git/git-9999.ebuild4
6 files changed, 12 insertions, 12 deletions
diff --git a/dev-vcs/git/git-2.32.0.ebuild b/dev-vcs/git/git-2.32.0-r1.ebuild
index cbb9b5aff2c3..46eab6b9e4a7 100644
--- a/dev-vcs/git/git-2.32.0.ebuild
+++ b/dev-vcs/git/git-2.32.0-r1.ebuild
@@ -6,7 +6,7 @@ EAPI=7
GENTOO_DEPEND_ON_PERL=no
# bug #329479: git-remote-testgit is not multiple-version aware
-PYTHON_COMPAT=( python3_{7..10} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit toolchain-funcs elisp-common perl-module bash-completion-r1 plocale python-single-r1 systemd
@@ -61,7 +61,7 @@ DEPEND="
)
dev-libs/openssl:0=
sys-libs/zlib
- pcre? ( dev-libs/libpcre2 )
+ pcre? ( dev-libs/libpcre2:= )
perl? ( dev-lang/perl:=[-build(-)] )
tk? ( dev-lang/tk:0= )
curl? (
diff --git a/dev-vcs/git/git-2.33.0.ebuild b/dev-vcs/git/git-2.33.0-r1.ebuild
index f1efa2f3c23e..b3f952ce377e 100644
--- a/dev-vcs/git/git-2.33.0.ebuild
+++ b/dev-vcs/git/git-2.33.0-r1.ebuild
@@ -6,7 +6,7 @@ EAPI=7
GENTOO_DEPEND_ON_PERL=no
# bug #329479: git-remote-testgit is not multiple-version aware
-PYTHON_COMPAT=( python3_{7..10} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit toolchain-funcs elisp-common perl-module bash-completion-r1 plocale python-single-r1 systemd
@@ -61,7 +61,7 @@ DEPEND="
)
dev-libs/openssl:0=
sys-libs/zlib
- pcre? ( dev-libs/libpcre2 )
+ pcre? ( dev-libs/libpcre2:= )
perl? ( dev-lang/perl:=[-build(-)] )
tk? ( dev-lang/tk:0= )
curl? (
diff --git a/dev-vcs/git/git-9999-r1.ebuild b/dev-vcs/git/git-9999-r1.ebuild
index 4f8854e669b8..252c3e3bc1bb 100644
--- a/dev-vcs/git/git-9999-r1.ebuild
+++ b/dev-vcs/git/git-9999-r1.ebuild
@@ -6,7 +6,7 @@ EAPI=7
GENTOO_DEPEND_ON_PERL=no
# bug #329479: git-remote-testgit is not multiple-version aware
-PYTHON_COMPAT=( python3_{7..10} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit toolchain-funcs elisp-common perl-module bash-completion-r1 plocale python-single-r1 systemd
@@ -61,7 +61,7 @@ DEPEND="
)
dev-libs/openssl:0=
sys-libs/zlib
- pcre? ( dev-libs/libpcre2 )
+ pcre? ( dev-libs/libpcre2:= )
perl? ( dev-lang/perl:=[-build(-)] )
tk? ( dev-lang/tk:0= )
curl? (
diff --git a/dev-vcs/git/git-9999-r2.ebuild b/dev-vcs/git/git-9999-r2.ebuild
index 4f8854e669b8..252c3e3bc1bb 100644
--- a/dev-vcs/git/git-9999-r2.ebuild
+++ b/dev-vcs/git/git-9999-r2.ebuild
@@ -6,7 +6,7 @@ EAPI=7
GENTOO_DEPEND_ON_PERL=no
# bug #329479: git-remote-testgit is not multiple-version aware
-PYTHON_COMPAT=( python3_{7..10} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit toolchain-funcs elisp-common perl-module bash-completion-r1 plocale python-single-r1 systemd
@@ -61,7 +61,7 @@ DEPEND="
)
dev-libs/openssl:0=
sys-libs/zlib
- pcre? ( dev-libs/libpcre2 )
+ pcre? ( dev-libs/libpcre2:= )
perl? ( dev-lang/perl:=[-build(-)] )
tk? ( dev-lang/tk:0= )
curl? (
diff --git a/dev-vcs/git/git-9999-r3.ebuild b/dev-vcs/git/git-9999-r3.ebuild
index 2648a8293fa2..40a7dede3c1d 100644
--- a/dev-vcs/git/git-9999-r3.ebuild
+++ b/dev-vcs/git/git-9999-r3.ebuild
@@ -6,7 +6,7 @@ EAPI=7
GENTOO_DEPEND_ON_PERL=no
# bug #329479: git-remote-testgit is not multiple-version aware
-PYTHON_COMPAT=( python3_{7..10} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit toolchain-funcs elisp-common perl-module bash-completion-r1 plocale python-single-r1 systemd
@@ -61,7 +61,7 @@ DEPEND="
)
dev-libs/openssl:0=
sys-libs/zlib
- pcre? ( dev-libs/libpcre2 )
+ pcre? ( dev-libs/libpcre2:= )
perl? ( dev-lang/perl:=[-build(-)] )
tk? ( dev-lang/tk:0= )
curl? (
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index dfebf26eef28..4a1d6a07b908 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=7
GENTOO_DEPEND_ON_PERL=no
# bug #329479: git-remote-testgit is not multiple-version aware
-PYTHON_COMPAT=( python3_{7..10} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit toolchain-funcs elisp-common perl-module bash-completion-r1 plocale python-single-r1 systemd
@@ -61,7 +61,7 @@ DEPEND="
)
dev-libs/openssl:0=
sys-libs/zlib
- pcre? ( dev-libs/libpcre2 )
+ pcre? ( dev-libs/libpcre2:= )
perl? ( dev-lang/perl:=[-build(-)] )
tk? ( dev-lang/tk:0= )
curl? (