summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-05 06:54:04 +0000
committerSam James <sam@gentoo.org>2024-03-05 06:54:04 +0000
commite262261bcff223146ce1e6c39966d89617d82d9e (patch)
treeca32a3929e539b1c350c71d7eb4fd4c27252f636
parentapp-shells/squirrelsh: filter LTO, no SA (diff)
downloadgentoo-e262261bcff223146ce1e6c39966d89617d82d9e.tar.gz
gentoo-e262261bcff223146ce1e6c39966d89617d82d9e.tar.bz2
gentoo-e262261bcff223146ce1e6c39966d89617d82d9e.zip
dev-util/uftrace: filter LTO
There's an upstream bug not yet fixed. Filter LTO until it's fixed to avoid tinderbox failures. Closes: https://bugs.gentoo.org/858503 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/uftrace/uftrace-0.14.ebuild5
-rw-r--r--dev-util/uftrace/uftrace-0.15.2.ebuild5
2 files changed, 8 insertions, 2 deletions
diff --git a/dev-util/uftrace/uftrace-0.14.ebuild b/dev-util/uftrace/uftrace-0.14.ebuild
index d8951e47e6fd..20f0fe2eb878 100644
--- a/dev-util/uftrace/uftrace-0.14.ebuild
+++ b/dev-util/uftrace/uftrace-0.14.ebuild
@@ -6,7 +6,7 @@ EAPI=8
LUA_COMPAT=( luajit )
PYTHON_COMPAT=( python3_{9..12} )
-inherit bash-completion-r1 lua-single python-single-r1 toolchain-funcs
+inherit bash-completion-r1 flag-o-matic lua-single python-single-r1 toolchain-funcs
DESCRIPTION="Function (graph) tracer for user-space"
HOMEPAGE="https://github.com/namhyung/uftrace"
@@ -40,6 +40,9 @@ src_prepare() {
}
src_configure() {
+ # bug #858503 (https://github.com/namhyung/uftrace/issues/1343)
+ filter-lto
+
local myconf=(
--libdir="${EPREFIX}/usr/$(get_libdir)/uftrace"
$(use_with capstone)
diff --git a/dev-util/uftrace/uftrace-0.15.2.ebuild b/dev-util/uftrace/uftrace-0.15.2.ebuild
index ffe4bfb99f16..bc09d5c8ccae 100644
--- a/dev-util/uftrace/uftrace-0.15.2.ebuild
+++ b/dev-util/uftrace/uftrace-0.15.2.ebuild
@@ -6,7 +6,7 @@ EAPI=8
LUA_COMPAT=( luajit )
PYTHON_COMPAT=( python3_{9..12} )
-inherit bash-completion-r1 lua-single python-single-r1 toolchain-funcs
+inherit bash-completion-r1 flag-o-matic lua-single python-single-r1 toolchain-funcs
DESCRIPTION="Function (graph) tracer for user-space"
HOMEPAGE="https://github.com/namhyung/uftrace"
@@ -40,6 +40,9 @@ src_prepare() {
}
src_configure() {
+ # bug #858503 (https://github.com/namhyung/uftrace/issues/1343)
+ filter-lto
+
local myconf=(
--libdir="${EPREFIX}/usr/$(get_libdir)/uftrace"
$(use_with capstone)