summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMing Dai <radaiming@gmail.com>2016-04-18 19:14:01 +0800
committerIan Delaney <idella4@gentoo.org>2016-04-18 23:18:58 +0800
commite2661df28715c33045239c563cafebc80b8a88c9 (patch)
tree93c5fb1654186bd5dbeecc5399a21bb2b7144b3e
parentprofiles: remove obsolete use.mask entries for x11-themes/gtk-engines-qtcurve (diff)
downloadgentoo-e2661df28715c33045239c563cafebc80b8a88c9.tar.gz
gentoo-e2661df28715c33045239c563cafebc80b8a88c9.tar.bz2
gentoo-e2661df28715c33045239c563cafebc80b8a88c9.zip
dev-python/urwid: Use python_is_python3 to determine current Python implementation
Package-Manager: portage-2.2.26 Closes: https://github.com/gentoo/gentoo/pull/1296 Signed-off-by: Ian Delaney <idella4@gentoo.org>
-rw-r--r--dev-python/urwid/urwid-1.3.1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-python/urwid/urwid-1.3.1.ebuild b/dev-python/urwid/urwid-1.3.1.ebuild
index 892d50866db2..0fa8a9fbeb76 100644
--- a/dev-python/urwid/urwid-1.3.1.ebuild
+++ b/dev-python/urwid/urwid-1.3.1.ebuild
@@ -27,7 +27,7 @@ PATCHES=( "${FILESDIR}"/${PN}-1.1.0-sphinx.patch )
python_compile_all() {
if use doc ; then
- if [[ ${EPYTHON} == python3* ]] ; then
+ if python_is_python3; then
2to3 -nw --no-diffs docs/conf.py || die
fi
cd docs
@@ -36,7 +36,7 @@ python_compile_all() {
}
python_compile() {
- if [[ ${EPYTHON} == python2* ]] ; then
+ if ! python_is_python3; then
local CFLAGS="${CFLAGS} -fno-strict-aliasing"
export CFLAGS
fi