summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James (sam_c) <sam@cmpct.info>2020-06-11 21:56:13 +0000
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-06-11 19:35:58 -0700
commite286ef56f3a147c6ff8ab9f5a46618e0fcdb936c (patch)
tree378dc3a0404ce2383ad903d6998d5c334a02f246
parentnet-dns/dnscrypt-proxy: run tests (diff)
downloadgentoo-e286ef56f3a147c6ff8ab9f5a46618e0fcdb936c.tar.gz
gentoo-e286ef56f3a147c6ff8ab9f5a46618e0fcdb936c.tar.bz2
gentoo-e286ef56f3a147c6ff8ab9f5a46618e0fcdb936c.zip
net-dns/dnscrypt-proxy: bump to 2.0.44
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Sam James (sam_c) <sam@cmpct.info> Closes: https://github.com/gentoo/gentoo/pull/16198 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--net-dns/dnscrypt-proxy/Manifest1
-rw-r--r--net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.44.ebuild105
2 files changed, 106 insertions, 0 deletions
diff --git a/net-dns/dnscrypt-proxy/Manifest b/net-dns/dnscrypt-proxy/Manifest
index 2f04d7b30a8a..70d7d128cb16 100644
--- a/net-dns/dnscrypt-proxy/Manifest
+++ b/net-dns/dnscrypt-proxy/Manifest
@@ -1,3 +1,4 @@
DIST dnscrypt-proxy-2.0.41.tar.gz 2323421 BLAKE2B 572a0ad15df6c40d1738b296972584f5d8fe382ca3c0a05b4fc74e986e767a058227dda2127c843127bc0b90e8b7bbe17a5eaee42175f0b77e21160ac63f7a88 SHA512 26be163daa03633f2d76f1121fb1987e0155613bd84cbb2aad2ba0eedbd35ec0b393d1c1a0aaba47968b3a08bd0273ad929a164695ce35d2ebe05ce3b5f5dfd1
DIST dnscrypt-proxy-2.0.42.tar.gz 2324442 BLAKE2B 8444eca1fc2bfc6029c1848bbeb77697b9b9c228c1bd0d17ed357b73667524c7052b33410a92847743533c3712f749fd93dbac46a81da48dae367e2a515cad8c SHA512 093b07ee8eb44c1264e6ea4b60ad32e0221b1b02c1d61f142b1fbf37dc5181533cc3c5d6e7468d0f7488611de4620947684269da9f08f21da0aa501ba70be711
DIST dnscrypt-proxy-2.0.43.tar.gz 2279744 BLAKE2B f06892bc14da2be2e97dfb5d233420cf3726e359ccd0658d4309981291a12a7cac7a7592d11717a9466144bd5cb9d9a4e1b6ba8877a8b5c539783749588a10a1 SHA512 a1d14756d6be6450683a44adae197aa582df2556dda588debdadd0903b5993a4dc579880479f138ec3690045aeab833a19f23b2555a403930d26d4a5bc90ed5f
+DIST dnscrypt-proxy-2.0.44.tar.gz 2279842 BLAKE2B 90f156914dd29ab5baa2eb02ed2992583999a6688d09a532f8c7c1ec6d285bd39893f66726da928f295056fd66cd756f4332f1ed21284ffa3d357ce355a08625 SHA512 009e2b669c1d6f6cd6b41f5e04d08735587f420dacdea8d422a3c12a62614c1ce1963deebca3af1f956070abd9ff5df9182cb27e31fa0fac8a95478739445801
diff --git a/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.44.ebuild b/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.44.ebuild
new file mode 100644
index 000000000000..bfc4fef8eb03
--- /dev/null
+++ b/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.44.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGO_PN="github.com/DNSCrypt/${PN}"
+
+inherit fcaps go-module systemd
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://${EGO_PN}.git"
+else
+ SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+DESCRIPTION="A flexible DNS proxy, with support for encrypted DNS protocols"
+HOMEPAGE="https://github.com/DNSCrypt/dnscrypt-proxy"
+
+LICENSE="Apache-2.0 BSD ISC MIT MPL-2.0"
+SLOT="0"
+IUSE="pie"
+
+BDEPEND=">=dev-lang/go-1.13"
+
+RDEPEND="
+ acct-group/dnscrypt-proxy
+ acct-user/dnscrypt-proxy
+"
+
+FILECAPS=( cap_net_bind_service+ep usr/bin/dnscrypt-proxy )
+
+PATCHES=( "${FILESDIR}"/config-full-paths-r11.patch )
+
+src_compile() {
+ pushd "${PN}" >/dev/null || die
+ go build -v -x -mod=readonly -mod=vendor -buildmode="$(usex pie pie default)" || die
+ popd >/dev/null || die
+}
+
+src_test() {
+ cd "${PN}" || die
+ go test -mod=vendor -buildmode="$(usex pie pie default)" || die "Failed to run tests"
+}
+
+src_install() {
+ pushd "${PN}" >/dev/null || die
+
+ dobin dnscrypt-proxy
+
+ insinto /etc/dnscrypt-proxy
+ newins example-dnscrypt-proxy.toml dnscrypt-proxy.toml
+ doins example-{blacklist.txt,whitelist.txt}
+ doins example-{cloaking-rules.txt,forwarding-rules.txt}
+
+ popd >/dev/null || die
+
+ insinto /usr/share/dnscrypt-proxy
+ doins -r "utils/generate-domains-blacklists/."
+
+ newinitd "${FILESDIR}"/dnscrypt-proxy.initd dnscrypt-proxy
+ newconfd "${FILESDIR}"/dnscrypt-proxy.confd dnscrypt-proxy
+
+ systemd_newunit "${FILESDIR}"/dnscrypt-proxy.service dnscrypt-proxy.service
+ systemd_newunit "${FILESDIR}"/dnscrypt-proxy.socket dnscrypt-proxy.socket
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/dnscrypt-proxy.logrotate dnscrypt-proxy
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ fcaps_pkg_postinst
+ go-module_pkg_postinst
+
+ if ! use filecaps; then
+ ewarn "'filecaps' USE flag is disabled"
+ ewarn "${PN} will fail to listen on port 53"
+ ewarn "please do one the following:"
+ ewarn "1) re-enable 'filecaps'"
+ ewarn "2) change port to > 1024"
+ ewarn "3) configure to run ${PN} as root (not recommended)"
+ ewarn
+ fi
+
+ if systemd_is_booted || has_version sys-apps/systemd; then
+ elog "Using systemd socket activation may cause issues with speed"
+ elog "latency and reliability of ${PN} and is discouraged by upstream"
+ elog "Existing installations advised to disable 'dnscrypt-proxy.socket'"
+ elog "It is disabled by default for new installations"
+ elog "check "$(systemd_get_systemunitdir)/${PN}.service" for details"
+ elog
+
+ fi
+
+ elog "After starting the service you will need to update your"
+ elog "/etc/resolv.conf and replace your current set of resolvers"
+ elog "with:"
+ elog
+ elog "nameserver 127.0.0.1"
+ elog
+ elog "Also see https://github.com/DNSCrypt/${PN}/wiki"
+}