summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-11 12:19:52 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-11 13:24:29 +0200
commite28b216720731f15bf747adc5ad7a5a3ba440736 (patch)
treebf4bb9f1ae83b4ae626e7eff8bd6325d987888d7
parentdev-python/testtools: Add python3.5 support (diff)
downloadgentoo-e28b216720731f15bf747adc5ad7a5a3ba440736.tar.gz
gentoo-e28b216720731f15bf747adc5ad7a5a3ba440736.tar.bz2
gentoo-e28b216720731f15bf747adc5ad7a5a3ba440736.zip
dev-python/extras: Add python3.5 support
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/extras/extras-0.0.3-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/extras/extras-0.0.3-r1.ebuild b/dev-python/extras/extras-0.0.3-r1.ebuild
new file mode 100644
index 000000000000..cd914dae022f
--- /dev/null
+++ b/dev-python/extras/extras-0.0.3-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Useful extra bits for Python that should be in the standard library"
+HOMEPAGE="https://github.com/testing-cabal/extras/ https://pypi.python.org/pypi/extras/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/testtools[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+python_test() {
+ "${PYTHON}" ${PN}/tests/test_extras.py || die
+}