summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-12-02 09:25:11 +0100
committerLars Wendler <polynomial-c@gentoo.org>2015-12-02 09:27:46 +0100
commite2bcf8d877920add0d48a50d7299cad85c80cf74 (patch)
tree4d88aaf27b61928504f73d512ed0584002861ec4
parentdev-vcs/mercurial: Removed old. (diff)
downloadgentoo-e2bcf8d877920add0d48a50d7299cad85c80cf74.tar.gz
gentoo-e2bcf8d877920add0d48a50d7299cad85c80cf74.tar.bz2
gentoo-e2bcf8d877920add0d48a50d7299cad85c80cf74.zip
net-fs/samba: Bump to version 4.3.2
Package-Manager: portage-2.2.26 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--net-fs/samba/Manifest1
-rw-r--r--net-fs/samba/samba-4.3.2.ebuild196
2 files changed, 197 insertions, 0 deletions
diff --git a/net-fs/samba/Manifest b/net-fs/samba/Manifest
index dab76f2a4ac0..5007bc2db77b 100644
--- a/net-fs/samba/Manifest
+++ b/net-fs/samba/Manifest
@@ -8,4 +8,5 @@ DIST samba-4.2.4.tar.gz 20735687 SHA256 fb326ea486973ab684f183774e93bb943fc231ab
DIST samba-4.2.5.tar.gz 20734836 SHA256 8191c4c0730daf7f9e9a3ea1cc6e680798d76bf855269807778adcccc8d706cf SHA512 b3581bd6ff33ce107ab2fb3cc8797852e441ed296df680083bcb25164941c08f870c2edadf5cf41280648c012bb264274854890ca8704ba17289a30efbbd1709 WHIRLPOOL a35bf488b81ba8f753871db35c611b2ad99b90e8bf6afd97df85785a9c84e1d7ad120a76832c09347031e0c895346e150ae9c7353e6bee16e4beccfbeaf7fad8
DIST samba-4.3.0.tar.gz 20417699 SHA256 d8dbb6b29dec1d9aa295655c4aa4eadd1e5367ef7047be22f4d6a18ba8acdb63 SHA512 7edad171dd98a332ebfd51c7c380b1def3d1508399755fc2d333671ce4a7d5e73782871c5760341cb71460d3f7fc4b666d906d61b9e2b28f977301d08bc9a872 WHIRLPOOL cd204bb122cc344b63b01aebc151aeb01e533402eb511ba7c440fc718a568f8004f754a4502c74dfd58869e2e22cfd0f9822c2602e3642da5b69d2bdd2b76d39
DIST samba-4.3.1.tar.gz 20424516 SHA256 9908a80d95b9e2583906ed4347a8c80b769539a2788158992fb48ea9fb4d2c82 SHA512 4a7c7e27e0d231b852b47407fb51cbe2b7851138d9a957c8149346afe1b14a2afa8fff66505abdbafe1ea43fc78b53800941c96c925fbc281b9ff24ef5ecfc98 WHIRLPOOL de09a933e222acf60e03a085370d218f26c917d98fde77535f55ca2f4a3bdcda0877fc8e0666c17ab271731ecdfa34e4ad4425fe83460a169d9ee2061007f059
+DIST samba-4.3.2.tar.gz 20425622 SHA256 61989195caadf0f6fb51ce6bed5e203e6146facc2c276a26ad41901ad9129a75 SHA512 b01330c3e56731c1749e2179b160233c852c739c394be7999f9792e27891679ae2a15bbad50d8917a08a40b39ae3c6990ae2aa0f6345871d51058d234dad2528 WHIRLPOOL 21f4a6d240c57c66ca2159ecb8898f8f79dcb9ebfb85d66224ac31e2fbb365e2f4227a800af3a2934a50616b27cc6bb636a9a1a5d0e6ce57276c0a2e633d13bf
DIST smb_traffic_analyzer_v2.diff.bz2 12226 SHA256 1bae7eafbe8ac2382313d5ab9d43d73ba64b63a714f0f588516952d476fb868d SHA512 aa0e457a0dd282e61e6dfcd5705c29b319832dca9711b1b5baf8373e2f079991399c3537c050219ccb861a93f86353ebff677a5c625d2e3f1f3a13ee5c4087d0 WHIRLPOOL 85ee72a360f67ebe71be5cd400ecd635280a0d7c64ebb8b94656a5ef1a94f74a987de86408af00ce1b81cc8363b1b3cf14726860d29b72ee610d4bab73d6b139
diff --git a/net-fs/samba/samba-4.3.2.ebuild b/net-fs/samba/samba-4.3.2.ebuild
new file mode 100644
index 000000000000..d53b9790291d
--- /dev/null
+++ b/net-fs/samba/samba-4.3.2.ebuild
@@ -0,0 +1,196 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE='threads(+)'
+
+inherit python-single-r1 waf-utils multilib linux-info systemd eutils
+
+MY_PV="${PV/_rc/rc}"
+MY_P="${PN}-${MY_PV}"
+
+SRC_PATH="stable"
+[[ ${PV} = *_rc* ]] && SRC_PATH="rc"
+
+SRC_URI="mirror://samba/${SRC_PATH}/${MY_P}.tar.gz"
+KEYWORDS="~amd64 ~hppa ~x86"
+[[ ${PV} = *_rc* ]] && KEYWORDS="~hppa"
+
+DESCRIPTION="Samba Suite Version 4"
+HOMEPAGE="http://www.samba.org/"
+LICENSE="GPL-3"
+
+SLOT="0"
+
+IUSE="acl addc addns ads aio avahi client cluster cups dmapi fam gnutls iprint
+ldap pam quota selinux syslog +system-mitkrb5 systemd test winbind"
+
+# sys-apps/attr is an automagic dependency (see bug #489748)
+# sys-libs/pam is an automagic dependency (see bug #489770)
+CDEPEND="${PYTHON_DEPS}
+ dev-libs/iniparser:0
+ dev-libs/popt
+ sys-libs/readline:=
+ virtual/libiconv
+ dev-python/subunit[${PYTHON_USEDEP}]
+ >=net-libs/socket_wrapper-1.1.3
+ sys-apps/attr
+ sys-libs/libcap
+ >=sys-libs/ldb-1.1.21
+ sys-libs/ncurses:0=
+ >=sys-libs/nss_wrapper-1.0.3
+ >=sys-libs/talloc-2.1.3[python,${PYTHON_USEDEP}]
+ >=sys-libs/tdb-1.3.7[python,${PYTHON_USEDEP}]
+ >=sys-libs/tevent-0.9.25
+ >=sys-libs/uid_wrapper-1.1.0
+ sys-libs/zlib
+ virtual/pam
+ acl? ( virtual/acl )
+ addns? ( net-dns/bind-tools[gssapi] )
+ aio? ( dev-libs/libaio )
+ cluster? ( >=dev-db/ctdb-1.0.114_p1 )
+ cups? ( net-print/cups )
+ dmapi? ( sys-apps/dmapi )
+ fam? ( virtual/fam )
+ gnutls? ( dev-libs/libgcrypt:0
+ >=net-libs/gnutls-1.4.0 )
+ ldap? ( net-nds/openldap )
+ system-mitkrb5? ( app-crypt/mit-krb5 )
+ !system-mitkrb5? ( >=app-crypt/heimdal-1.5[-ssl] )
+ systemd? ( sys-apps/systemd:0= )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ client? ( net-fs/cifs-utils[ads?] )
+ selinux? ( sec-policy/selinux-samba )
+"
+
+REQUIRED_USE="addc? ( gnutls !system-mitkrb5 )
+ ads? ( acl gnutls ldap )
+ ${PYTHON_REQUIRED_USE}"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}/${PN}-4.2.3-heimdal_compilefix.patch" )
+
+CONFDIR="${FILESDIR}/$(get_version_component_range 1-2)"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ if use aio ; then
+ if ! linux_config_exists || ! linux_chkconfig_present AIO; then
+ ewarn "You must enable AIO support in your kernel config, "
+ ewarn "to be able to support asynchronous I/O. "
+ ewarn "You can find it at"
+ ewarn
+ ewarn "General Support"
+ ewarn " Enable AIO support "
+ ewarn
+ ewarn "and recompile your kernel..."
+ fi
+ fi
+ if ! use pam ; then
+ ewarn "You have pam USE flag disabled!"
+ ewarn "Unfortunately we still have to hard depend on virtual/pam as samba upstream"
+ ewarn "still unconditionally links libauth4-samba4.so library to libpam.so once being"
+ ewarn "found on the sytem."
+ ewarn "Disabling the pam USE flag only disables installation of samba's pam authenti-"
+ ewarn "cation modules."
+ fi
+}
+
+src_prepare() {
+ epatch ${PATCHES[@]}
+}
+
+src_configure() {
+ local myconf=()
+ myconf=(
+ --enable-fhs
+ --sysconfdir=/etc
+ --localstatedir=/var
+ --with-modulesdir=/usr/$(get_libdir)/samba
+ --with-piddir=/var/run/${PN}
+ --bundled-libraries=NONE
+ --builtin-libraries=NONE
+ --disable-rpath
+ --disable-rpath-install
+ --nopyc
+ --nopyo
+ $(use_with acl acl-support)
+ $(usex addc '' '--without-ad-dc')
+ $(use_with addns dnsupdate)
+ $(use_with ads)
+ $(usex ads '--with-shared-modules=idmap_ad' '')
+ $(use_with aio aio-support)
+ $(usex cluster '--with-ctdb-dir=/usr' '')
+ $(use_enable avahi)
+ $(use_with cluster cluster-support)
+ $(use_enable cups)
+ $(use_with dmapi)
+ $(use_with fam)
+ $(use_enable gnutls)
+ $(use_enable iprint)
+ $(use_with ldap)
+ $(use_with pam)
+ $(use_with pam pam_smbpass)
+ $(usex pam "--with-pammodulesdir=/$(get_libdir)/security" '')
+ $(use_with quota quotas)
+ $(use_with syslog)
+ $(use_with systemd)
+ $(usex system-mitkrb5 '--with-system-mitkrb5' '')
+ $(use_with winbind)
+ $(usex test '--enable-selftest' '')
+ )
+
+ CPPFLAGS="-I${SYSROOT}/usr/include/et ${CPPFLAGS}" \
+ waf-utils_src_configure ${myconf[@]}
+}
+
+src_install() {
+ waf-utils_src_install
+
+ # install ldap schema for server (bug #491002)
+ if use ldap ; then
+ insinto /etc/openldap/schema
+ doins examples/LDAP/samba.schema
+ fi
+
+ # Make all .so files executable
+ find "${D}" -type f -name "*.so" -exec chmod +x {} +
+
+ # install example config file
+ insinto /etc/samba
+ doins examples/smb.conf.default
+
+ # Install init script and conf.d file
+ newinitd "${CONFDIR}/samba4.initd-r1" samba
+ newconfd "${CONFDIR}/samba4.confd" samba
+
+ systemd_dotmpfilesd "${FILESDIR}"/samba.conf
+ systemd_dounit "${FILESDIR}"/nmbd.service
+ systemd_dounit "${FILESDIR}"/smbd.{service,socket}
+ systemd_newunit "${FILESDIR}"/smbd_at.service 'smbd@.service'
+ systemd_dounit "${FILESDIR}"/winbindd.service
+ systemd_dounit "${FILESDIR}"/samba.service
+}
+
+src_test() {
+ "${WAF_BINARY}" test || die "test failed"
+}
+
+pkg_postinst() {
+ ewarn "Be aware the this release contains the best of all of Samba's"
+ ewarn "technology parts, both a file server (that you can reasonably expect"
+ ewarn "to upgrade existing Samba 3.x releases to) and the AD domain"
+ ewarn "controller work previously known as 'samba4'."
+
+ elog "For further information and migration steps make sure to read "
+ elog "http://samba.org/samba/history/${P}.html "
+ elog "http://samba.org/samba/history/${PN}-4.2.0.html and"
+ elog "http://wiki.samba.org/index.php/Samba4/HOWTO "
+}