summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-05-21 17:30:18 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-05-21 17:30:18 +0200
commite2c103e048145ae90f945d9603519d537c98d747 (patch)
treeed424fe19957ff36523f0449e750fd9f92d14c0c
parentapp-emacs/ssass-mode: new package; add 0.2_p20200211 (diff)
downloadgentoo-e2c103e048145ae90f945d9603519d537c98d747.tar.gz
gentoo-e2c103e048145ae90f945d9603519d537c98d747.tar.bz2
gentoo-e2c103e048145ae90f945d9603519d537c98d747.zip
app-emacs/vue-html-mode: new package; add 0.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/vue-html-mode/Manifest1
-rw-r--r--app-emacs/vue-html-mode/files/50vue-html-mode-gentoo.el3
-rw-r--r--app-emacs/vue-html-mode/metadata.xml21
-rw-r--r--app-emacs/vue-html-mode/vue-html-mode-0.2.ebuild24
4 files changed, 49 insertions, 0 deletions
diff --git a/app-emacs/vue-html-mode/Manifest b/app-emacs/vue-html-mode/Manifest
new file mode 100644
index 000000000000..dc03a9acea22
--- /dev/null
+++ b/app-emacs/vue-html-mode/Manifest
@@ -0,0 +1 @@
+DIST vue-html-mode-0.2.tar.gz 17744 BLAKE2B 460a6f67c00d3b2e7372209766c2dc1729ff5ac1ef9ca8951ac0677937130d5b54cb3c22702d304efe70aa57117af067b6a103197738efa1f5ee77f285e01c18 SHA512 8fe8f19059d64355af9ae2ac95aba2ac71b50153f5a3270fd75b70433bce3fa628a04abe03dea84671dabe5c604b7b0ae298b33214038ef9fa5dff8aaf418a56
diff --git a/app-emacs/vue-html-mode/files/50vue-html-mode-gentoo.el b/app-emacs/vue-html-mode/files/50vue-html-mode-gentoo.el
new file mode 100644
index 000000000000..0bc482778051
--- /dev/null
+++ b/app-emacs/vue-html-mode/files/50vue-html-mode-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'vue-html-mode "vue-html-mode"
+ "Major mode for Vue.js templates." t)
diff --git a/app-emacs/vue-html-mode/metadata.xml b/app-emacs/vue-html-mode/metadata.xml
new file mode 100644
index 000000000000..d51da01a3b2d
--- /dev/null
+++ b/app-emacs/vue-html-mode/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ The main features of this mode are syntax highlighting (enabled with
+ font-lock-mode or global-font-lock-mode), and html-mode integration. Vue
+ component files are best edited with the excellent vue-mode, which the
+ author of this package also contributes to. This mode is included in
+ vue-mode, and is the default mode for editing template blocks.
+ </longdescription>
+ <stabilize-allarches />
+ <upstream>
+ <bugs-to>https://github.com/AdamNiederer/vue-html-mode/issues/</bugs-to>
+ <remote-id type="github">AdamNiederer/vue-html-mode</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/vue-html-mode/vue-html-mode-0.2.ebuild b/app-emacs/vue-html-mode/vue-html-mode-0.2.ebuild
new file mode 100644
index 000000000000..420647bc0094
--- /dev/null
+++ b/app-emacs/vue-html-mode/vue-html-mode-0.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Major Emacs mode for editing Vue.js templates"
+HOMEPAGE="https://github.com/AdamNiederer/vue-html-mode/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/AdamNiederer/${PN}.git"
+else
+ SRC_URI="https://github.com/AdamNiederer/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"