summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-09 07:43:45 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-09 09:08:00 +0200
commite2ce0174d5d8a0bd4f4cac2382d2f7bbfee6bad3 (patch)
tree26517497d11321324bc473604f489793c522741d
parentdev-python/hypothesis: Bump to 6.23.2 (diff)
downloadgentoo-e2ce0174d5d8a0bd4f4cac2382d2f7bbfee6bad3.tar.gz
gentoo-e2ce0174d5d8a0bd4f4cac2382d2f7bbfee6bad3.tar.bz2
gentoo-e2ce0174d5d8a0bd4f4cac2382d2f7bbfee6bad3.zip
dev-python/botocore: Bump to 1.21.58
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.21.58.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 5a0b1c01308f..cd9c64dcdeeb 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -6,3 +6,4 @@ DIST botocore-1.21.54.tar.gz 8221388 BLAKE2B ea72e84b9ba5cb4d97a3a353f3fdd2fe808
DIST botocore-1.21.55.tar.gz 8225756 BLAKE2B 8a0d333802cc196552d905c61716f601e2725c1b19a296a3e07b6f6e4b2deded5dadb68ab9de1aa5c2a07b34ec4c9eb333c2131e6a479998e150810a4b31e75e SHA512 2bd2bae733d2846c41415ddd07431abcd553f8220e87e228b1f91dd7b7af5b8f8918a43bd79a9b8d2b0196098c37b05eed6433859beb74f806bb20717ac41d8e
DIST botocore-1.21.56.tar.gz 8227172 BLAKE2B 0a783e76c0a4a3ea577661a5995fdb2e53658aa462a6e59a950979c3c35864e94df1848aa5af40270e03833797bcd48c45f633dd8fbb198b2913df975f59069a SHA512 cb4f3e72f8d0bb9451b6b748e3763f6456937938047a2d9a6c5f47c498329b6930bc324e7d6f296952816c96aeb74047f7c2e33044abb551d289d24659a406e5
DIST botocore-1.21.57.tar.gz 8239528 BLAKE2B d2b98f37468e0faf593d5fd42341dcab32d7ade253c80929722adbe7523ed6efb2b491a12b4335faf779703acc6eabbd3e1c6e0a02994d24dd13cea7d376bf6e SHA512 6bfcd57c7ac77c1098004e5e8a77c14a3718099eda5af00fbcaa0f54fabd93caf0ce66212c5807ae58d565cadfee25dfdcff9dcef8a68e66ba74f03ee28acfb9
+DIST botocore-1.21.58.tar.gz 8243903 BLAKE2B a8666451aa7e39114afce45d1eb82fed8f1747b6f994dc5ec76f8c675c363fd196c2c23d26738ca2a1c67e451d2eff1024d01ef97ff0dfb425d8fa85a9c0eef6 SHA512 424f13d7f3c5c2b3b2546cf42f22588a53c407867c8e2672c01f6c3791d101ff42f5d7a300cffbcccafdfc78f28a4386ef9acc4562de3c124198d1c898e5701d
diff --git a/dev-python/botocore/botocore-1.21.58.ebuild b/dev-python/botocore/botocore-1.21.58.ebuild
new file mode 100644
index 000000000000..638620b2cbc8
--- /dev/null
+++ b/dev-python/botocore/botocore-1.21.58.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ epytest tests/{functional,unit}
+}