summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-04-19 21:59:19 +0200
committerHans de Graaff <graaff@gentoo.org>2023-04-19 22:07:13 +0200
commite2d2cf30f4137eb1505e5a2095306bcad62791b7 (patch)
tree3659ea34f6e1509bef1a360e89df1835d5e85944
parentdev-ruby/sanitize: enable ruby32 (diff)
downloadgentoo-e2d2cf30f4137eb1505e5a2095306bcad62791b7.tar.gz
gentoo-e2d2cf30f4137eb1505e5a2095306bcad62791b7.tar.bz2
gentoo-e2d2cf30f4137eb1505e5a2095306bcad62791b7.zip
dev-ruby/debug_inspector: update EAPI 7 -> 8
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/debug_inspector/debug_inspector-1.1.0-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/debug_inspector/debug_inspector-1.1.0-r1.ebuild b/dev-ruby/debug_inspector/debug_inspector-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..dacb6b727da3
--- /dev/null
+++ b/dev-ruby/debug_inspector/debug_inspector-1.1.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/debug_inspector/extconf.rb)
+
+RUBY_FAKEGEM_GEMSPEC="debug_inspector.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby wrapper for the MRI 2.0 debug_inspector API"
+HOMEPAGE="https://github.com/banister/debug_inspector"
+SRC_URI="https://github.com/banister/debug_inspector/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/extensiontask/,$ s:^:#:' Rakefile || die
+}