summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-17 21:21:42 +0100
committerSam James <sam@gentoo.org>2022-06-17 21:24:49 +0100
commite2fe286f2d5c0ae959cb6daa0f3695a08fe4f32b (patch)
tree0fd4a6ada79d239f2adcdd158b94b907188126e5
parentx11-drivers/nvidia-drivers: add 515.49.05:0/vulkan (diff)
downloadgentoo-e2fe286f.tar.gz
gentoo-e2fe286f.tar.bz2
gentoo-e2fe286f.zip
app-shells/bash: only dep on readline if is_release
To match reality. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-shells/bash/bash-5.2_rc1.ebuild7
-rw-r--r--app-shells/bash/bash-9999.ebuild16
2 files changed, 20 insertions, 3 deletions
diff --git a/app-shells/bash/bash-5.2_rc1.ebuild b/app-shells/bash/bash-5.2_rc1.ebuild
index af272883e190..30812eac26e8 100644
--- a/app-shells/bash/bash-5.2_rc1.ebuild
+++ b/app-shells/bash/bash-5.2_rc1.ebuild
@@ -75,8 +75,10 @@ IUSE="afs bashlogger examples mem-scramble +net nls plugins +readline"
DEPEND="
>=sys-libs/ncurses-5.2-r2:0=
nls? ( virtual/libintl )
- readline? ( >=sys-libs/readline-${READLINE_VER}:0= )
"
+if is_release ; then
+ DEPEND+=" readline? ( >=sys-libs/readline-${READLINE_VER}:= )"
+fi
RDEPEND="
${DEPEND}
"
@@ -86,6 +88,9 @@ BDEPEND="verify-sig? ( sec-keys/openpgp-keys-chetramey )"
S="${WORKDIR}/${MY_P}"
+# EAPI 8 tries to append it but it doesn't exist here
+QA_CONFIGURE_OPTIONS+="--disable-static"
+
PATCHES=(
#"${WORKDIR}"/${PN}-${GENTOO_PATCH_VER}/
diff --git a/app-shells/bash/bash-9999.ebuild b/app-shells/bash/bash-9999.ebuild
index f36854ee07d4..30812eac26e8 100644
--- a/app-shells/bash/bash-9999.ebuild
+++ b/app-shells/bash/bash-9999.ebuild
@@ -65,7 +65,7 @@ if [[ -n ${GENTOO_PATCH_VER} ]] ; then
SRC_URI+=" https://dev.gentoo.org/~${GENTOO_PATCH_DEV}/distfiles/${CATEGORY}/${PN}/${PN}-${GENTOO_PATCH_VER}-patches.tar.xz"
fi
-LICENSE="GPL-3"
+LICENSE="GPL-3+"
SLOT="0"
if is_release ; then
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
@@ -75,8 +75,10 @@ IUSE="afs bashlogger examples mem-scramble +net nls plugins +readline"
DEPEND="
>=sys-libs/ncurses-5.2-r2:0=
nls? ( virtual/libintl )
- readline? ( >=sys-libs/readline-${READLINE_VER}:0= )
"
+if is_release ; then
+ DEPEND+=" readline? ( >=sys-libs/readline-${READLINE_VER}:= )"
+fi
RDEPEND="
${DEPEND}
"
@@ -86,6 +88,9 @@ BDEPEND="verify-sig? ( sec-keys/openpgp-keys-chetramey )"
S="${WORKDIR}/${MY_P}"
+# EAPI 8 tries to append it but it doesn't exist here
+QA_CONFIGURE_OPTIONS+="--disable-static"
+
PATCHES=(
#"${WORKDIR}"/${PN}-${GENTOO_PATCH_VER}/
@@ -222,6 +227,13 @@ src_compile() {
fi
}
+src_test() {
+ # Used in test suite.
+ unset A
+
+ default
+}
+
src_install() {
local d f